HTTP Error 500.19 - Internal Server ErrorRSS

15 replies

Last post Oct 09, 2006 03:17 AM by gsacavdm

  • HTTP Error 500.19 - Internal Server Error

    Jun 04, 2006 05:42 PM|Kenty2006|LINK

    Hi. I have a problem with iis7. Whenever i try to access any website in iis i get this error:

    Server Error in '' Application.


    HTTP Error 500.19 - Internal Server Error

    Description: The requested page cannot be accessed because the related configuration data for the page is invalid in the metabase on the Web server.

    Error Code: 0x80070005

    Notification: BeginRequest

    Module: IIS Web Core

    Requested URL: http://www.livepedia.com:80/

    Physical Path: C:\Websites\livepedia.com

    Logon User: (empty)

    Logon Method: (empty)

    Handler: (empty)

    Config Error: Cannot read configuration file

    Config File: \\?\C:\Websites\livepedia.com\web.config    Line: 0

    Causes:

    • The worker process is unable to read the applicationhost.config or web.config file.
    • There is malformed XML in the applicationhost.config or web.config file.

    Solution:

    • Look in the event logs for information about why the configuration files could not be read.
    • Make sure the user identity specified for the application pool has the required permissions to access the web application and server configuration files.

    Anyone knows hwow to fix this ? Thx.

  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 04, 2006 05:47 PM|Kenty2006|LINK

    The event log says :

    Could not load all ISAPI filters for site/service. Therefore startup aborted.

  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 05, 2006 10:26 AM|tomkmvp|LINK

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 05, 2006 11:04 PM|qbernard|LINK

    You should one more event log entry indicating what dll can't be loaded.... post it here.
    Cheers,
    Bernard Cheah
  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 06, 2006 03:12 AM|Kenty2006|LINK

    Im trying to figure it out. I have another log now :

    The description for Event ID "2268" from Source "Microsoft-Windows-IIS-W3SVC-WP" cannot be found. The local computer may not have the event source installed.

    "The handle is invalid"

    I cant find what isapi dll cant be loadead.

  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 06, 2006 06:32 AM|qbernard|LINK

    Ha! no idea. but from the error msgs, it looks like something is not installed :) No other event log with more clues?
    Cheers,
    Bernard Cheah
  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 08, 2006 04:11 PM|thomad|LINK

    see next post
    Thomas Deml
    Group Program Manager
    Internet Information Services
    Microsoft Corp.
  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 08, 2006 04:12 PM|thomad|LINK

    Might be an permissions issue:

    Can you run the following command and send the output?

    cacls C:\Websites\livepedia.com

    Thomas Deml
    Group Program Manager
    Internet Information Services
    Microsoft Corp.
  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 13, 2006 07:13 PM|iiscool|LINK

    I remember seeing such incomplete eventlog messages when I am trying to view the Vista-machine-eventlog from a non-vista machine (2k3 or XP).

    You should open the event viewer from the vista machine to see all the detailed event logs. Once you get the detailed event log message, post it to this forum.

  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 17, 2006 01:46 AM|Kenty2006|LINK

    I reinstalled Windows and works perfectly fine now. Thanks.
  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 17, 2006 02:47 AM|qbernard|LINK

    Wow :)
    Cheers,
    Bernard Cheah
  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 19, 2006 02:41 PM|mangalsingh|LINK

    I had XP Pro SP2 with VS2003 and VS2005 installed. I had a few ASP.NET1.1 apps that are giving me the same problems after upgrading to Vista. I guess I'll have to do a clean install if I intend to make it work too. Thats such a pain in the ***. I have to sit through 3+ hrs of vista install and then 2 hrs with Visual Studio. Not much work possible today. But then again.. its beta... so my bad that I installed it on my work machine.

    Mangal

  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 26, 2006 06:54 PM|mangalsingh|LINK

    Reinstalled Win Vista and still no help. Can somebody tell me whats going on. I have also disabled user account protection (this I did for various other reasons).

    Thanks

  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 26, 2006 08:46 PM|iiscool|LINK

    What is the environment, What are you trying to do, what is the failure message; any event or FREB logs; whats in the web.config.

    I think, if you can put more details you could see a more useful (and quicker!) response.

  • Re: HTTP Error 500.19 - Internal Server Error

    Jun 27, 2006 02:24 PM|tomkmvp|LINK

    ... this is the wrong forum for help with IIS 7/Vista ... !!!
    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: HTTP Error 500.19 - Internal Server Error

    Oct 09, 2006 03:17 AM|gsacavdm|LINK

    Hi, I just ran into the same problem, and I've found the solution, for my case at least. If the site your trying to host is outside inetpub wwwroot then you need to grant IIS access to the folder.

     You can do that by:

    1. Right click the folder where your site is located: "C:\Users\Me\My Site" and selecting Properties

    2. Select the Security tab and click on Edit (for Windows Vista Only)

    3. Add.. and type in "IIS_IUSRS" ... OK

    That should do it.