lo all & plz help!!:-)RSS

15 replies

Last post Oct 22, 2005 05:55 PM by wasted

  • lo all & plz help!!:-)

    Oct 09, 2005 10:01 PM|wasted|LINK

    lo all,
    i'am learning all my web stuff from lynda.com and getting ok untill i started Dynamic Developmant Using ASP and Macromedia dreamweaver mx2004...i loaded iis from my xp pro o/s disk d/led microsoft asp the tryed to open a local host and it says...you are not authorized to view this page then i put in http://localhost/localstart.asp and i get a username and password promt..that i dont have:-(i look in the iis manager and got it the username i think...my pc name then a password[well not just 10 dots where it is:-)] i tryed changing username and password but it still wont let me in:-(.i download the asp server from here hoping it would help but its the same...i know its proberly something simple 2 ulot:-)but a nightmare for me.
    thx for any help
    Charlie/Wasted
    P.s i tryed in both my browsers ie/firefox..ie does'nt wamt to know,the other things i get[errors are from firefox]

  • Re: lo all & plz help!!:-)

    Oct 10, 2005 05:04 AM|deepak.vasudevan|LINK

    Hi,

    To have IIS serve content to all users you can select 'Anonymous'. You can allow IIS to control the password. Since you have modified these settings, you may need to visit this URL to sanitize your IIS Security Settings first:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;297989

    ------------------------------
    Deepak Vasudevan
    http://www.lavanyadeepak.tk/
    -------
  • Re: lo all & plz help!!:-)

    Oct 11, 2005 05:01 PM|wasted|LINK

    thx m8,i'll try that now:-)
    cya
    charlie/wasted

  • Re: lo all & plz help!!:-)

    Oct 12, 2005 07:44 PM|wasted|LINK

    lo again all,
    i tryed everthing on that page and still the same problem:(IE just says "Server Application Error", doesn't even ask for  a username/password.firefox still asks but wont take the username's or password i have set in the 3 places:-(..
    thx for any help
    charlie/wasted
    P.s Is there another program that is better than  IIS?


  • Re: lo all & plz help!!:-)

    Oct 13, 2005 08:43 AM|tomkmvp|LINK

    I don't think that article is going to help you.

    If you're getting prompted for a password it means that you are not allowing anonymous access to your web site.  Make sure the IUSR_computername account has NTFS read permissions on C:\inetpub\wwwroot.  See http://support.microsoft.com/default.aspx?scid=kb;en-us;q301457&sd=tech.

    As for the error, see this first:  http://www.aspfaq.com/show.asp?id=2109.

    A better program than IIS?  If you're having trouble with this I can't imagine anything else being easier for you ...

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: lo all & plz help!!:-)

    Oct 13, 2005 07:12 PM|wasted|LINK

    tryed that now i dont get a username/password prompt, i get http 401.1 :-(.if i installed windows server 2003 think that would help?
    thx
    Charlie
    p.s is coldfusion anygood?i'am not great with html but i know abit...i no nothing about any other:-)

  • Re: lo all & plz help!!:-)

    Oct 14, 2005 08:29 AM|tomkmvp|LINK

    401.1 means that IIS cannot authenticate the user.  Make sure the IUSR password specified in the IIS MMC matches the one given for the account.  Just reset the password for the account so it's the same in both places.
    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: lo all & plz help!!:-)

    Oct 15, 2005 07:46 PM|wasted|LINK

    lo again:-)
    i've done everything in from the 2 post links and still the same...no password prompt and no access,ive tryed other stuff i found in google and its still the same.so i uninstalled it then resarted doing the stuff from the links on the post and its still the same:-(install coldfusion still the same....anyother ideas?
    thx
    Charlie

  • Re: lo all & plz help!!:-)

    Oct 16, 2005 10:23 PM|jeff@zina.com|LINK

    Test with a Hello World HTML file and post the full error message.

    Jeff

    Have you Binged a solution before posting?
  • Re: lo all & plz help!!:-)

    Oct 18, 2005 07:17 PM|wasted|LINK

    i did a test html page and it worked NP on IE but came up in firefox with this on the page "<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252%>" as well as the test text...i tryed a test.asp page and it never worked:-(.
    thx for anymore help:-)
    charlie

  • Re: lo all & plz help!!:-)

    Oct 19, 2005 06:26 AM|jeff@zina.com|LINK

    wasted

    i did a test html page and it worked NP on IE but came up in firefox with this on the page "<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252%>" as well as the test text...i tryed a test.asp page and it never worked:-(.
    thx for anymore help:-)


    The ASP extension is still mapped to ASP.DLL?  You're running other than IIS6 or running IIS6 and have enabled ASP as a web extension?  The IE vs Firefox portion still points to authentication issues, have you removed all but anonymous authentication fo the site?

    Jeff
    Have you Binged a solution before posting?
  • Re: lo all & plz help!!:-)

    Oct 19, 2005 06:15 PM|wasted|LINK

    me bad..:)
    i just checked and i'am on iis 5.1 so went to microsoft and it would'nt let me D/l v6 god knows why my xp pro is legit....so iv been having a couple of other windows problems too so i'll format over the weekend and install v6.hopfully that should fix this...
    ill post back after the format
    Thx alot
    Charlie

  • Re: lo all & plz help!!:-)

    Oct 21, 2005 04:38 PM|jeff@zina.com|LINK

    Your version of IIS depends on the operating system.  XP is 5.1, Server 2003 is 6.0.  You can't download IIS anywhere.

    Jeff

    Have you Binged a solution before posting?
  • Re: lo all & plz help!!:-)

    Oct 21, 2005 07:26 PM|wasted|LINK


    cheers m8,
    i need 2 format anyway:-(hopfully it might help....when i reinstall xp pro should i set a admin pass?and if i installed server 2003 could i use it like a normal operating system, as in install the usall stuff that runs on win xp and 2000.
    cheers
    Charlie
    P.s should i set it up as 2 o.p's and use 2003 for iis and stuff like that?
  • Re: lo all & plz help!!:-)

    Oct 21, 2005 10:46 PM|jeff@zina.com|LINK

    First, install a workstation operating system if you're going to use the system as a workstation.  I have no idea why you think you need IIS6 so I can't advise you much more than that.

    Second, always use an administrator account and password, otherwise anyone can log into the system.

    Jeff

    Have you Binged a solution before posting?
  • Re: lo all & plz help!!:-)

    Oct 22, 2005 05:55 PM|wasted|LINK

    lo all:-)
    after the format it works no problem:D,so all i have to do now is the easy bit....learn how to make/use databases;-)
    thx everyone