We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

please, help - 'HTTP/1.1 500 Internal Server Error.' RSS

32 replies

Last post Mar 17, 2008 01:43 AM by qbernard

  • please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 26, 2005 11:15 AM|Brisk|LINK

    I have a trouble - I can't create assembly based on 'ASP.NET Web Application' template in VS.NET enviroment. The following error appears after I click 'Ok' in 'New Project' dialog box:

    "the Web server reported the following error when attempting to create or open the Web project located at the following URL: 'http://localhost/WebApplicaton1'.'HTTP/1.1 500 Internal Server Error.'"

    I could not receive additional information neither looking to log files, not unchecking "Show friendly HTTP error messages." :(
    What is installed on my computer: Windows Prfessional with ServPack4, IIS 5.1, IE 6.0, .NET Framework 1.1, VS.NET 2003.

    I tried to change userName attribute of machine.config file (under WINNT\Microsoft.NET\Framework\v1.1.4322\CONFIG) typing user with administrative rights, but nothing changed:(

    Is any idea how to solve the problem?

    Thank you in advance!

    Yuri
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 26, 2005 02:45 PM|tomkmvp|LINK

    Any related messages appearing in the System or Application event logs?
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 27, 2005 01:27 AM|Brisk|LINK

    No one messaage is added to both logs.
    Yuri
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 27, 2005 01:34 AM|Brisk|LINK

    No one message is added to both logs.
    Yuri
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 27, 2005 03:16 AM|qbernard|LINK

    There's should be log entires in event log. Can you try disable IE friendly msgs, then try access again and check the even log ? with detail error msgs it's very hard to troubleshoot.

    Cheers,
    Bernard Cheah
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 27, 2005 03:34 AM|Brisk|LINK

    As I mentioed above, I disabled "Show friendly HTTP error messages" checkbox in IE options. It would help you only in case of receiving message in the IE browser, but I received it in Visual Studio dialog box. 
    Before I started New Project, I cleared log errors. Then, I looked to the log again after receiving the abovementioned error message - both System or Application logs are empty.
    No additional information is added to IIS log - only the same 'HTTP/1.1 500 Internal Server Error'.

    I reinstalled IIS, and VS.NET with .NET Framevork, but it did not help :(

    Yuri
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 27, 2005 08:30 AM|tomkmvp|LINK

    What happens if you try to browse a simple ASP?  Make a file named hello.asp and place it in C:\inetpub\wwwroot:

    <%
    Response.Write "Hello World"
    %>

    Browse to it as http://localhost/hello.asp
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 27, 2005 08:51 AM|Brisk|LINK

    tomkmvp,

    Thank you a lot! I found a reason of the problem. It was great idea to start from browsing ASP file!

    How I found the reason of my problem:

    I did what you proposed - any ASP file works fine. Once I renamed it to hello.aspx, and browsed to http://localhost/hello.aspx, the error message appears: "Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately."
    Source File: c:\inetpub\wwwroot\web.config    Line: 0

    I looked to web.config  in web root - it is empty! I removed web.config and then ASPX-file is corretly displayed now as well as VS.NET projects are correcly created! So the reason of my problem was empty web.config file placed in web root directory (I don't know when and how in was placed there). The interesting thing is that this fact influenced on ASP.NET Web Application project creation.

    I appreciate your help!
    Yuri
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 27, 2005 11:27 AM|tomkmvp|LINK

    You're welcome, but more importantly thanks for thinking ahead and trying an aspx ...
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 18, 2005 10:22 AM|RickCrone|LINK

    I'm having the same HTTP/1.1 500 error but I do have something in my system logs.

    <div>I'm getting a HTTP /1.1 500 Server Error when I try to create a new ASP.NET web application.

    I'm using VS 2003.

    I have a local IIS running.

    I think I must have some configuration incorrect, but I don't know what to change. Any suggestions?

    The system log show:

    The server failed to load application '/LM/W3SVC'. The error was 'The specified metadata was not found'

    I tried to create a simple hello.asp and put it in wwwroot. When I tried to

    browse to it the system log showed:

    The server failed to load application '/LM/W3SVC/1/root'. The error was 'Class not registered'.

    Before doing all this I have run Aspnet_Regiis.exe /i and I think it was successful.</div>
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 18, 2005 03:26 PM|tomkmvp|LINK

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 18, 2005 04:39 PM|RickCrone|LINK

    Thanks! I did find that I needed to reinstall DTC but that has not 'fixed' my issue.

    I will check out each of the items in your link... they look promissing. I only have about another hour to work on this today... and then I can try again Tuesday.

    Thanks again.... and I'll be back   hopefully with a success story!

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 21, 2005 09:30 PM|qbernard|LINK

    For the class not registered error, try
    http://msmvps.com/bernard/archive/2005/03/22/39216.aspx
    Cheers,
    Bernard Cheah
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 23, 2005 09:38 AM|RickCrone|LINK

    Thank you. I have NOT tried the things listed on that link yet... but I do have some additional information:

    I had loaded MDE 2002 with Dot Net 1.0 and have NOT unloaded it as I was moving only a few applications at time to the newer MDE 2003 Dot Net 1.1. I noticed that 'about' for 2002 list VS.NET but the 'about' for 2003 does not.

    I just tried using the older version to create the ASP.NET application and it worked! I'm still getting the error on MDE 2003. I remain confused... does any of this give you any idea what might be wrong?

    Maybe I can get some clue from the application that was created.

    I'll let you know what I find out.

     

     

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 23, 2005 11:38 AM|RickCrone|LINK

    qbernard

    For the class not registered error, try
    http://msmvps.com/bernard/archive/2005/03/22/39216.aspx


    That got it! At least the second part did. I think I had the Component Service working... and I couldn't figure out what to delete so I just followed the instructions b and c to create the IIS package and reset.

    Thanks!
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 24, 2005 10:36 AM|bens|LINK

    I am having the same issue except I am trying to connect to a distributed site. I do not have IIS running on my local box. I also do not have front page server extensions running. i do not know how to check the error log, so I can not tell you if I have any errors other then 'HTTP/1.1 500 Internal Server Error.'

    Thank you for any help

    bbenso1

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 24, 2005 10:47 AM|RickCrone|LINK

    I found some addition information in the event logs 'system events'. I would think this would be in the event logs on the server you are trying to use... but check local too.

    Mine had source: W3SVC.
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 24, 2005 11:54 AM|jeff@zina.com|LINK

    bens

    I am having the same issue except I am trying to connect to a distributed site. I do not have IIS running on my local box. I also do not have front page server extensions running. i do not know how to check the error log, so I can not tell you if I have any errors other then 'HTTP/1.1 500 Internal Server Error.'

    Thank you for any help



    You have the same symptom.  It may or may not be the same problem.  You need to check the Event Log on the server running IIS, using Event Viewer in Administrative Tools.  When you post back, you need to provide the full error message, plus the operating system the web server runs.  Whether a "Hello World!" page works or not would be helpful to know as well.

    Jeff

    Have you Binged a solution before posting?
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Aug 26, 2005 01:41 AM|qbernard|LINK

    Great! thanks for the update.
    Cheers,
    Bernard Cheah
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 31, 2006 07:44 AM|ranjit_jesus|LINK

    HI ALL,

    THANK YOU VERY MUCH FOR ALL YOUR VALUABLE SUGGESTIONS. IT HELPED ME IN ALL WAYS TO SETUP AND TROUBLESHOOT THE PROBLEMS RELATED TO FRESH INSTALLATION AND SETUP OF VS. THANKS AGAIN.

    CHEERS,
    RANJIT KUMAR

     

     

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    May 31, 2006 08:16 AM|tomkmvp|LINK

    Great! ... and be sure to check out the new forums at http://www.iis.net/ ...
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Jun 04, 2006 12:36 PM|osenturk|LINK

    Dear All,

    I Have same error.In Technet Windows XP and W2003 server does not support more than one asp.net versions.If your computer updated by WSUS or another way, you may have 2-3 asp.net versions.Create a batch file in notepad using this command,

     

    c:\windows\microsoft.net\framework\v1.1.4322\aspnet_regiis.exe -u
    c:\windows\microsoft.net\framework\v1.1.4322\aspnet_regiis.exe -i
    net stop iisadmin
    net start iisadmin
    net start w3svc

     

    Save this file (for exam) asp.bat and run it! Thats all.You can use your :net service.

     

    I hope this help your problem.

     

    Regards

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Jun 05, 2006 10:37 AM|tomkmvp|LINK

    Can you supply the link that says that more than one version is not supported?  I'd love to see that ...
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Jun 23, 2006 12:59 AM|dhaval4friends|LINK

    Hi All,
    i am getting the same errro
    'HTTP/1.1 500 Internal Server Error.' [V]

    here are my event logs
    [1]
    "aspnet_wp.exe could not be started. The error code for the failure is 80004005. This error can be caused when the worker process account has insufficient rights to read the .NET Framework files. Please ensure that the .NET Framework is correctly installed and that the ACLs on the installation directory allow access to the configured account. "

    [2]
    "aspnet_wp.exe could not be launched because the username and/or password supplied in the processModel section of the config file are invalid."

    i have tried

    - reseting IIS
    - restrating the system
    - aspnet user is there in Administrator Group
    - haven't made changes in machine.config

    Please anyone help me...

    Thanks in advance
    ~Dh@v@!


    Thank you,
    ~Dhaval
    http://blogfullofcrap.blogspot.com/
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Jun 23, 2006 03:06 AM|qbernard|LINK

    See if this help,
    "Aspnet_wp.exe could not be started" error message when you view an ASP.NET page
    http://support.microsoft.com/?id=811320

    if you still stuck with the problem, you can try filemon (sysinternals.com) to trace the access error.

    Cheers,
    Bernard Cheah
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Jun 26, 2006 12:54 AM|dhaval4friends|LINK

    <div id=_ctl0__ctl1_bcr_PostForm___Reply>Thnx qbernard,</div> <div>but the problem was much more simpler than it....</div> <div>my ASPNET account got locked... unlocked it and now its working..</div>

     


    Thank you,
    ~Dhaval
    http://blogfullofcrap.blogspot.com/
  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Nov 26, 2007 12:13 AM|pooja..|LINK

    Hello Jeff

    In order to overcome 'HTTP/1.1 500 Internal Server Error.' this problem you said that their is need to check the Event Log on the server running IIS, using Event Viewer in Administrative Tools....

    I have the same problem and according to urs solution i tried to sort it out bt i fount no event log for today Please help me what to do .........................

    Thanks

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Nov 27, 2007 02:19 AM|steve schofield|LINK

    Disable Show Friendly HTTP errors in IE and report the error. 

    Steve Schofield
    Windows Server MVP - IIS
    http://iislogs.com/steveschofield
    http://www.IISLogs.com
    Log archival solution
    Install, Configure, Forget

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Nov 28, 2007 05:02 AM|pooja..|LINK

    i sort out this problem

    thanks for yours consern....

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Mar 14, 2008 10:42 AM|lalitpathak21|LINK

    Hi,

    I am facing a problem with IIS sites, whenever I try to open any asp file , which does not exist, it gives me the HTTP/1.1 500 internal server error, I have disabled the option of sow friendly error messages also.

    When I try to run .html or .htm file(which doesnot exist), it returns 404 error message.

    The impact of this problem is that my 404 redirects using .asp files are not working.

    Any type of help is appreciated.

    Thanks in advance.....

     

    Lalit

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Mar 14, 2008 03:38 PM|tomkmvp|LINK

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Mar 15, 2008 03:00 AM|lalitpathak21|LINK

    Hi Tom,

    Thanks for the prompt reply.......

    I have gone through the link send by you but I was not lucky enough to find a solution there... Actually the problem whcih I am facing is a bit strange...

    When I try to browse the asp pages which are already there it gives no error, but when I try to browse for any asp page which is not there, I expect for 404 error page so that my 404 redirect works and gives the desired page.

    I got the 404 (page not found) error message when I use .aspx, .html , .htm extension with the non existing files, but as soon as I use test.asp, It gives me HTTP 1.1/500 Internal Server Error.

    Please Help.....

    Thanks in advance

    Lalit

     

  • Re: please, help - 'HTTP/1.1 500 Internal Server Error.'

    Mar 17, 2008 01:43 AM|qbernard|LINK

    Have you disable IE friendly error msgs?
    post the log entries for the entire event. from valid to not valid then 500.
    Anything in event log ?

    Cheers,
    Bernard Cheah