We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

server.transfer not workingRSS

3 replies

Last post Oct 18, 2004 08:36 AM by binoj7

  • server.transfer not working

    Sep 24, 2004 01:08 PM|AlexB1318|LINK

    Have a legacy ASP app that has the start page in a sub directory and a debug page in the root that has a link to the start page. Works fine for dev, however, for prod I want to go straight to the start page so I created a page called default.asp with one line of code: server.transfer "ASP PAGES/Main.asp" The problem is it doesn't do anything. Statement executes but nothing happens no errors, no nothing! Have also tried: server.transfer "./ASP PAGES/Main.asp" server.transfer (server.mappaht("ASP PAGES/Main.asp")) I know this is something small. Can anyone help?
  • Re: server.transfer not working

    Sep 24, 2004 05:22 PM|Fredrik2000|LINK

    I think you need to specify an absolute path when you're using server.transfer, have you tried Server.Transfer("http://localhost/ASP%20PAGES/Main.asp") ? Regards Fredr!k
  • Re: server.transfer not working

    Oct 05, 2004 09:33 PM|netguy|LINK

    Any reason why you are using Server.Redirect Why dont you use Response.Redirect(url)?
    ~ Innovative Modules @ Inspector IT
    ~ I Blog @ CTO 2.0
  • Re: server.transfer not working

    Oct 18, 2004 07:28 AM|binoj7|LINK

    Server.Transfer and Server.Exectute works only on Windows 2000 (IIS 5.0) and above. If you are using Windows 95/98/ NT 4.0 then these commands are not available for you...
    You cannot solve tomorrows problems with todays level of thinking - AE