We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

unable to create asp .net web application from studio 2003RSS

5 replies

Last post May 14, 2004 06:16 PM by kkalapan

  • unable to create asp .net web application from studio 2003

    May 14, 2004 12:12 PM|kkalapan|LINK

    os-> windows xp sp1 iis-> 5.1 ide -> visual studio .net 2003 framework-> v1.1.4322 When I click on new asp.net web application in studio I get an error saying 'Unable to establish connection with server'. I have tried following suggestions from another newsgroup with no luck: 1. If you are working on NTFS partition system, check weather all permissions for the group "Everyone" is checked for the Inetpub, wwwroot folders. 2. Internet Information Server 6.0 blocks all requests with extensions that are not explicitly mapped in the IIS. Microsoft Visual Studio .NET writes a file to the server with the .tmp extension and then requests that file back with an HTTP call to test the URL. IIS 6.0 blocks the .tmp file because .tmp files are not mapped. The call fails, and then you receive the File Not Found error message. To resolve this problem, add a MIME type for the .tmp file in IIS. To do so, follow these steps: 1. In Control Panel, open Administrative Tools, and then double-click Internet Information Services. 2. Expand the (local computer) node, and then expand Web Sites. 3. Right-click Default Web Site, and then click Properties. 4. In Default Web Site Properties, click the HTTP Headers Tab. 5. Click MIME Types. In MIME Types, click New to register a file extension. 6. In the Extension textbox, type .tmp . In the MIME Type textbox, type temp. 7. Click OK. 3. If you are using proxy server, check if "Bypass proxy server for local addresses" is checked under Internet Options > Connections > Lan Settings tab. 4. Check if server extensions and permissions are being configured for you IIS. 5. Right Click on Default Web Site on your IIS. Goto Home Directory. Check if Application name box is not empty. If empty, click Create button. A Default Application appears thereby. 6. Check if your IIS is registered for ASP.NET service. To achieve this goto "C:\WINNT\Microsoft.NET\Framework\v1.0.3705" directory from the console. (cd C:\WINNT\Microsoft.NET\Framework\v1.0.3705). Enter aspnet_regiis -i. unfortunately I have been at this for days. Any help would be greatly appreciated. Thanks.
  • Re: unable to create asp .net web application from studio 2003

    May 14, 2004 12:17 PM|master4eva|LINK

    Lets go back to the basics: what URL are you typing into your web browser?
    -- Justin Lovell
  • Re: unable to create asp .net web application from studio 2003

    May 14, 2004 02:44 PM|kkalapan|LINK

    Once more I get this when I click on new asp .net web application. The url for the project is http://localhost/.
  • Re: unable to create asp .net web application from studio 2003

    May 14, 2004 02:56 PM|master4eva|LINK

    Right... lets have a test whether or not your hosts file got edited -- go into command prompt and put in the following command: ping localhost If you do do not get any results (that the "host could not be found" or something like that) then I am onto what the problem is. Otherwise, I have a few added scenerios on what could be happening.
    -- Justin Lovell
  • Re: unable to create asp .net web application from studio 2003

    May 14, 2004 04:12 PM|tomkmvp|LINK

    Does this relate to your problem? http://support.microsoft.com/default.aspx?scid=kb;en-us;831685&Product=vsnet
  • Re: unable to create asp .net web application from studio 2003

    May 14, 2004 06:12 PM|kkalapan|LINK

    It was the firewall that was configured incorrectly ! studio .net requests were being blocked ! Thanks you all very much once again.