We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Server 2012 R2 + Webdav + issues mapping driveRSS

3 replies

Last post Dec 24, 2020 02:07 AM by Brucz

  • Server 2012 R2 + Webdav + issues mapping drive

    Dec 22, 2020 04:17 PM|pkuzniasz|LINK

    Server 2012 R2 with Webdav setup, server is remote to office.  Attempting to connect over the internet via HTTPS.

    I can access server via web browser (https://server:port/folder) - logon with defined user credentials.

    I am unable to map a drive or add as network location, which is what is really needed.

    Am seeing the connection attempt in IIS logs, and the following errors:

    401, 5, OPTIONS, /folder, -,
    200, 0, OPTIONS, /folder, -,
    401, 5, PROPFIND, /folder, -,
    405, 0, PROPFIND, /folder, -,

    SSL is required.  Authentication is set to Basic.  Directory browsing is enabled.

    Any idea why I cannot map a drive or add as network location?

    Thanks

  • Re: Server 2012 R2 + Webdav + issues mapping drive

    Dec 23, 2020 02:28 AM|Brucz|LINK

    Hi pkuzniasz,

    This is the correct steps to map a drive.

    1. Open file explorer and right click "This PC", click "Map network drive...".
    2. Enter the drive letter and the folder where you'll add or edit webdav files.
    3. Check Reconnect at sigh-in and Connect using different credentials boxes. Checking the Reconnect at sign-in box allows the webdav connection to be restored when your reboot your computer.
    4. Click the link "Connect to a Web site that you can use to store your documents and pictures." and click next.
    5. Click "Choose a custom network location", and click next.
    6. Enter the domain URL in the Internet or Network address field.
    7. Type webdav username and password. Then click OK.
    8. Click next and finish.

    If you cannot connect to webdav directory, one thing you need to update in the windows registry.

    1. Righ-click Start and select Run. Type regedit to open windows registry editor.
    2. Go to the path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters.
    3. Find BasicAuthLevel value. The value should be 2. If it is not right-click and select modify and change to 2.

    Best regards,

    Brucz

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: Server 2012 R2 + Webdav + issues mapping drive

    Dec 23, 2020 02:59 PM|pkuzniasz|LINK

    Brucz,

    I changed the registry entry on the PC (Win10 Pro) that I am testing from, was at 1, changed value to 2.  Also checked and server was set to 2.

    Can still browse via web browser, but cannot map drive or add network location.

    Map drive error: the network name cannot be found

    Network location error: the folder you entered does not appear to be valid

  • Re: Server 2012 R2 + Webdav + issues mapping drive

    Dec 24, 2020 02:07 AM|Brucz|LINK

    Hi pkuzniasz,

    You can check  machine's setting at HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order. The ProviderOrder should be LanmanWorkstation,RDPNP,webclient. If you find some empty entries in  the order, please delete it, make it like

    Another thing is you should start webclient service. Enter the command in cmd.

    sc config "WebClient" start=auto
    sc start "WebClient"

    Best regards,

    Brucz

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.