IIS showing old cert to browsers after new cert added and used in bindingsRSS

2 replies

Last post Aug 20, 2020 02:16 AM by Jalpa Panchal

  • IIS showing old cert to browsers after new cert added and used in bindings

    Aug 13, 2020 11:03 AM|Anthony81|LINK

    Hi All,

    I've recently renewed our companies wildcard certificate. This has now been applied to all sites with https bindings. The old wildcard certificate wass removed from the local machine machine certificate store. So totally gone..

    But for some reason when clients access the sites, the old certificate shows up!? I've tried fully deleting the binding and recreating it, but still the old certificate is shown. I've no idea why.

    Any ideas? Thanks in Advance

    Anthony  

  • Re: IIS showing old cert to browsers after new cert added and used in bindings

    Aug 14, 2020 09:40 AM|Jalpa Panchal|LINK

    Hi,

    After reneing the certificate import that certificate in iis then add that certifuacte in iis site bindings. restart the site after doing chnages. set the iis client cache setting.

    To configure a cache expiration date for a Web site or application you could follow the below steps:


    1)Open Internet Information Services (IIS) Manager.

    2)In the Connections pane, go to the site for which you want to disable caching.

    3)From the middle pane, select HTTP Response Headers.

    4)In the HTTP Response Headers pane, click Set Common Headers... in the Actions pane.

    5)In the Set Common HTTP Response Headers dialog box, check the box to expire Web content, select the option to expire after a specific interval or at a specific time, and then click OK.

    You could also refer below article for more detail information:

    https://docs.microsoft.com/en-us/iis/configuration/system.webserver/staticcontent/clientcache

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: IIS showing old cert to browsers after new cert added and used in bindings

    Aug 20, 2020 02:16 AM|Jalpa Panchal|LINK

    Hi,

    Is your issue solved?

    If your issue is solved then I request you to mark the helpful suggestion as an answer. This will help other people who face the same issue.

    If your issue still exists then try to refer the solution given by the community members.

    If then also you have any further questions then let us know about it.

    We will try to provide further suggestions to solve the issue.

    Thanks for your understanding.

    Regards

    Jalpa.

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.