ARR3.0 Http 404 error [Answered]RSS

5 replies

Last post Feb 20, 2020 03:15 AM by WilsonShen

  • ARR3.0 Http 404 error

    Feb 18, 2020 09:43 AM|WilsonShen|LINK

    Hi Gulus,

    I'd face a ARR 3.0 setup problem.

    I have install a new Windows Server 2019 STD with IIS feature and ARR 3.0 installed.

    And I create a Server Farms name "aplanning" and add 2 server "twbiwebvm04" "twbiwebvm05".

    And I'd confirm URL Rewrite rule been added automatically.

    If I use IE open  http;//twbiwebvm04/healthcheck.txt , it is worked ! 

    But if I open http://aplanning/healthcheck.txt . It popup a http 404 file or directory not found error !

    <div id="content"> <div class="content-container">

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    </div> </div>

    Regards,

    Wilson

  • Rovastar Rovastar

    5482 Posts

    MVP

    Moderator

    Re: ARR3.0 Http 404 error

    Feb 18, 2020 04:07 PM|Rovastar|LINK

    First establish if your request is even hitting the ARR server.

    Is the request hitting your back end server(s)?

    Do you have the correct bindings on your Webservers for the aplanning site?

    Where are you testing this from? Ideally when I think about this the client machine is a seperate machine to the ARR and that the seperate machines to the backend Web Servers.

    Make sure the farm is up and available.

    Then have a look to see what URL rewrite rules it triggers for your farm.
    https://forums.iis.net/t/1193146.aspx?Rule+not+working+as+expected+Use+Failed+Request+Tracing

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: ARR3.0 Http 404 error

    Feb 19, 2020 04:47 AM|Yuk Ding|LINK

    Hi WilsonShen,

    Have you checked whether your backend server has received the request? Please check IIS log to trace the request and sub-status code

    Besides, what error did you receive if you access the load balance via your front-end website instead of serverfarm name?

    Best Regards,

    Jokies Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.
  • Re: ARR3.0 Http 404 error

    Feb 19, 2020 09:29 AM|WilsonShen|LINK

    Hi Rovaster,

    Thank for your kindly support .

    I'd follow  FRT document ( https://docs.microsoft.com/en-us/iis/extensions/url-rewrite-module/using-failed-request-tracing-to-trace-rewrite-rules ) create article.aspx .

    And it's work at http://twbiwebvm04/article.aspx

    And I found FRT must enable via "Action Pane" 

    https://docs.microsoft.com/en-us/iis/troubleshoot/using-failed-request-tracing/using-failed-request-tracing-rules-to-troubleshoot-application-request-routing-arr

    And I'd try remove TWBIWEBVM04 and add new fresh server ( c01010099) to WebFarm .

    And check the http://aplanning/healthcheck.txt is working

    Looks like Http 404 error only happen at TWBIWEBVM04 server.

    But I don't know what's wrong with it !

    Regards,

    Thanks,

    Wilson

  • Re: ARR3.0 Http 404 error

    Feb 19, 2020 10:12 AM|WilsonShen|LINK

    Dears,

    Thanks all yours support!

    After do some more test.

    I found it might be my test web farm server TWBIWEBVM04 had some problem.

    And If I add a new fresh server to web farm and  remove TWBIWEBVM04 server.

    It continue normally !

    Regards,

    Wilson

  • Re: ARR3.0 Http 404 error

    Feb 20, 2020 03:15 AM|WilsonShen|LINK

    Hi All,

    I found the TWBIWEBVM04 IIS Server must some wrong.
    I'd try remove it from webfarm and add a fresh server C01010099. 

    And I found http;//aplanning worked!

    And I try to restore TWBIWEBVM04 to previous backup.

    And add it to webfarm. Then it worked without 404 error !

    Regards,

    Wilson