IIS10 beginner needs help getting server side include working (simple case)RSS

3 replies

Last post Nov 12, 2019 05:45 AM by Yuk Ding

  • IIS10 beginner needs help getting server side include working (simple case)

    Nov 11, 2019 03:18 PM|wb0gaz|LINK

    I am beginner with IIS (my first experience with IIS is on a windows 10 laptop.) I am currently using IIS10 (on Windows 10) to serve a very simple HTML page to local host user (127.0.0.1:portnumber.) So far it is working.

    Now, I would like to use server side include (SSI) so that common content among a small number of pages in my server can share the same HTML text (avoids re-editing many files when making a change in this area.) As I understand this makes use of ASP (for which I have zero experience), I looked briefly at ASP and think this might be helpful in the future for other purposes, so I'm diving into this area without any previous knowledge (beyond editing HTML files and using IIS for the first time at beginner level.)

    In Control Panel -> Administrative Tools -> Programs and Features -> Turn Windows Features on/off -> IIS -> WWW Services -> Application Development Features, I currently have ASP, ISAPI Features, and Server-Side includes checked. All other settings are as originally installed.

    Symptoms:

    If I add #include directive in my index.html file, the #include directive is ignored - the #include directive is formed from a modified HTML comment and I believe I've formatted it properly (I'm just trying include a different file from within the index.html file; both files are in the same directory on the windows 10 machine.)

    <!--#include file="ToBeInserted.html"-->

    If I copied my index.html file to index.asp (no changes in content, just making a new file up with .ASP), then access the file from browser, I get IIS 10.0 Detailed Error - 404.3 - The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map. As the file is not displayed on the browser at all, I cannot determine what would happen if it encountered the #include directive.

    Many thanks for beginner-level help in getting this working!

    Dave

  • Re: IIS10 beginner needs help getting server side include working (simple case)

    Nov 11, 2019 05:03 PM|lextm|LINK

    Both SSI and ASP are decades old (pre-2000), and they are widely considered as dead technologies, and have almost zero active user community out there.

    Even as a beginner, you should now take a look at things like Angular/PHP/ASP.NET Core, simpler and highly promoted by their user communities. A search engine like Google can lead you to tons of modern information on them.

    Lex Li
    Affordable IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: IIS10 beginner needs help getting server side include working (simple case)

    Nov 11, 2019 07:05 PM|wb0gaz|LINK

    I appreciate the alternative suggestions - currently, this task is a kind of one-off and I'm trying to minimize the number of platforms I need to involve and learn to complete the task (which right now mostly needs a server-side include function.)

    If I further constrain my original ask to "sticking with IIS 10.0", would you (or someone here) be able guide me through getting server-side includes operating with what I already have available? That would provide a short-term solution to the immediate need and allow me to continue forward.

    Thanks again,


    Dave

  • Re: IIS10 beginner needs help getting server side include working (simple case)

    Nov 12, 2019 05:45 AM|Yuk Ding|LINK

    Hi  wb0gaz,

    When you install SSI on your IIS server, it will only work for .stm,.shtm,.shtml.

    So if you want to make it work for basic html or htm,

    1.You could go to IIS manager->handler mapping.

    2.If you want to enable SSI for html, you could set it like this.

    Once the handler mapping is set correctly, you will see it work

    If the reply is helpful, it is appreciated if you could mark it as answer.

    Best Regards,

    Jokies Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.