We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

asp.net default account not working IISRSS

3 replies

Last post Oct 30, 2019 02:50 AM by Jalpa Panchal

  • asp.net default account not working IIS

    Oct 29, 2019 12:15 AM|sweetSteel|LINK

    I created a website using asp.net default Account ( user, membership, profile etc). 

    By default, the database was placed in the app_Data folder.

    I copied the data and place it in a new folder so I am no longer using the localDB but MSSql server.

    this works fine on my local machine. 

    However, when I upload the project to IIS server 2012 its starts behaving strangely. 

    I already have some test users in the DB like testUeser.  

    If I try login as testUser with the correct password it would redirected to default.aspx which its suppose to but testUser will not be login. 

    If I try testuser with the wrong password it would say wrong user or password please try again like normal.

    If I try to register testUser again it will say user already Registered like normal.

    The only thing for some reason does allow testuser or any user to login.

    Help, please...thanks

  • Re: asp.net default account not working IIS

    Oct 29, 2019 02:38 AM|Jalpa Panchal|LINK

    Hi,

    Could you share your login code and connection string?

    please check under which application pool identity your application pool is running in the old server and 2012 server. 

    also, check anonymous authentication is enabled and the rest are disabled. 

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: asp.net default account not working IIS

    Oct 29, 2019 01:44 PM|sweetSteel|LINK

    <connectionStrings>
    <add name="DefaultConnection" connectionString="Data Source=.;Initial Catalog= myApp-20170220153012; User ID=sa; Password=xxxxxxxxxxxx" providerName="System.Data.SqlClient" />
    </connectionStrings>

    application pool on the local machine  is Clr4IntegratedAppPool 

    application pool on the server is .Net V4.5 Classic

    login code

    RegisterHyperLink.NavigateUrl = "Register";
    //OpenAuthLogin.ReturnUrl = Request.QueryString["ReturnUrl"]; for social media

    var returnUrl = HttpUtility.UrlEncode(Request.QueryString["ReturnUrl"]);
    if (!String.IsNullOrEmpty(returnUrl))
    {
    RegisterHyperLink.NavigateUrl += "?ReturnUrl=" + returnUrl;
    }

    thanks

    
    
  • Re: asp.net default account not working IIS

    Oct 30, 2019 02:50 AM|Jalpa Panchal|LINK

    why you changed the application pool from integrated to classic application pool? 

    could you share both application pool advance setting snapshot? 

    To check the application pool identity you could follow the below steps:
    1)open iis manager.
    2)select application pools and select your application pool name from the middle pane.
    3)select the advance setting from the action pane.

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.