enable logging for internet explorer for an internal website.RSS

21 replies

Last post Nov 25, 2019 11:45 AM by arcolino

  • enable logging for internet explorer for an internal website.

    Sep 27, 2019 12:27 AM|arcolino|LINK

    Hi,

    win 10 enterprise ver 1809 

    ie 11

    generic error:

    "Server Error 500 Internal Server Error - There is a problem with the resource you are looking for, and it cannot be displayed"

    for some reason internet explorer logging is not enabled in event viewer, and the ways to enable it through the registry does not work. is there a group policy setting or somewhere on the IIS server I can see the session of the clients browser and the error it is producing? or is there a setting I can use on IIS to adjust the security on the website? (its an internal site, not facing internet) would like to see why it works on some computers and not others. thx for helping and or pointing me in the right direction. 

    I found a debug feature in i/e 11, 

    the debug session says

    console (red x) 1

    red x 1 warning 0 message 1 

    red x script16389 unspecified error

    operations manager (1,1)

    html1300 navigation occured

    operations manager 

    I searched  script16389 it says possible java issue, 

    but other machine its working on, does not even have java installed. 

  • Re: enable logging for internet explorer for an internal website.

    Sep 27, 2019 04:42 AM|lextm|LINK

    arcolino

    "Server Error 500 Internal Server Error - There is a problem with the resource you are looking for, and it cannot be displayed"

    That's a server side error, so you should debug your web site (ASP, ASP.NET, PHP or any other web stack). Your following on IE 11 and Java is simply on the wrong track.

    Lex Li
    Affordable IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: enable logging for internet explorer for an internal website.

    Sep 27, 2019 05:30 AM|arcolino|LINK

    its on iis 10, its an internal site for scom web browser, 

    how do i debug it? sorry not an web browser tech, also keep in mind it works with I sign in with admin account but on the regular account i get that error, 

  • Re: enable logging for internet explorer for an internal website.

    Sep 27, 2019 06:10 AM|Jalpa Panchal|LINK

    Hi,

    Could you share which application you are using (asp.net,php, classic asp)? 

    try to enable the detailed error in iis by following below steps:

    1)Open iis manager, select Website and on its features view, double click on “Error Pages”.

    2)Select the “Edit Feature Settings…” or select the same from the Actions pane (in the right-hand side)

    3)Select the “Detailed errors” radio button and click on OK

    4)restart the site and try to reproduce an issue.

    also, check the iis log which is located at %SystemDrive%\inetpub\logs\LogFiles for the sub status code. 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 01:21 AM|arcolino|LINK

    its an IIS 10, 

    I believe its asp.net 

    after changes and reloading the page it now says

    on ie 11 

    http 500

    <div class="infoBlock" id="infoBlockID">

    This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

    For more information about HTTP errors, see Help.

    </div>

    on chrome 

    This page isn’t working
    computername.fqdn is currently unable to handle this request.
    HTTP ERROR 500

    C:\inetpub\logs\LogFiles\W3SVC1
    log file u_ex19100101

    output of log
    #Software: Microsoft Internet Information Services 10.0
    #Version: 1.0
    #Date: 2019-10-01 01:08:58
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) cs(Referer) sc-status sc-substatus sc-win32-status time-taken
    2019-10-01 01:08:58 127.0.0.1 GET /OperationsManager - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MyApp+1.0;+Windows+NT+5.1) - 401 2 5 0
    2019-10-01 01:08:58 127.0.0.1 GET /OperationsManager - 80 domain\computer name 127.0.0.1 Mozilla/4.0+(compatible;+MyApp+1.0;+Windows+NT+5.1) - 301 0 0 0
    2019-10-01 01:08:58 127.0.0.1 GET /OperationsManager/ - 80 domain\computername 127.0.0.1 Mozilla/4.0+(compatible;+MyApp+1.0;+Windows+NT+5.1) - 403 0 0 31
    #Software: Microsoft Internet Information Services 10.0

    I enabled failedreqlogfiles this morning but still no output? nothing in folder. 

  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 01:56 AM|Jalpa Panchal|LINK

    is this log file is the site which you get 500 error? because browser shows 500 and in the log file its shows 401, 301 and 403.

    please share the detailed error message snapshot.

    IIS events are logged in the Application log in event viewer.

    Also, check that do you multiple config files in your site folder?

    Go to menu Tools/Internet Options in your IE.
    - Click on the Advanced tab, uncheck "Show friendly HTTP error messages" option and click Ok.
    - Try accessing your web page again. Now you will see much more meaningful error message which will help you to troubleshoot the problem.

    Viewing IIS Event and Error Messages

    Regards,

    Jalpa

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 03:26 AM|arcolino|LINK

    I checked event viewer\application no iis entries

    I checked event viewer\applications and services logs\microsoft\windows\iis-logging\logs 

    its blank ?

    only one .config in c:\inetpub\wwwroot called web.config

    I unchecked show show friendly http error messages

    refreshed the page, its returned blank 


    I checked folder inetpub\I see folders
    custerr
    history
    logs
    temp


    this is from
    C:\inetpub\logs\LogFiles\W3SVC1\u_ex19100103

    2019-10-01 03:13:21 150.226.16.7 GET /OperationsManager/ - 80 domain\username ip address Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+WOW64;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729) - 500 0 0 78
    2019-10-01 03:13:23 150.226.16.7 GET /OperationsManager/ - 80 domain\username ip address Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+10.0;+WOW64;+Trident/7.0;+.NET4.0C;+.NET4.0E;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729) - 500 0 0 62

  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 03:43 AM|arcolino|LINK

    trying to get to that page I did f12 to debut and see network traffic on the client machine

    network

    showing the correct name

    result 500 internal error

    operations manager 

    (yellow triangle) html1527 DOCTYPE expected. Consider adding a valid HTML5 doctype: "<!DOCTYPE html>".

  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 06:33 AM|Jalpa Panchal|LINK

    try to debug the application by following below article steps:

    Remote Debug ASP.NET on a Remote IIS Computer

    Debug ASP.NET or ASP.NET Core apps in Visual Studio

    try to set allow the user to access the site using authorization rule:

    <configuration>
       <system.webServer>
          <security>
             <authorization>
                <remove users="*" roles="" verbs="" />
                <add accessType="Allow" users="" roles="Administrators" />
             </authorization>
          </security>
       </system.webServer>
    </configuration>

    set permission for another user to the site folder. 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 12:57 PM|arcolino|LINK

    ok, you may be on to something it should be where anybody should be able to view, 

    should be no permissions to view page, can you tell if that is what the issue is?

    part of the setup here is where you use a card with certs on there to access most things. 

    this page should not have any permish. and folks can view but cant change anything on the page....

    I just tested that view only page on a server that it works on, I cant change anything on the page which is the way it should be. 

    but the url will not even come up on some machines...

  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 02:31 PM|arcolino|LINK

    how do I make the site https? 

  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 07:52 PM|arcolino|LINK

    ok I modified the web.config 

    file, now its back to giving the 500 - internal server error, there is a problem with the resource...

    it broke the good working page on the server, I flipped it back to what it was. 

    btw this is whats in the web.config file let me know if anything jumps out at you.

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <httpErrors errorMode="Detailed" />
    </system.webServer>
    </configuration>

  • Re: enable logging for internet explorer for an internal website.

    Oct 01, 2019 08:25 PM|arcolino|LINK

    ok I changed the title after the server slash and now its giving more detailed message. 

    --------------

    HTTP Error 403.4 - Forbidden
    The page you are trying to access is secured with Secure Sockets Layer (SSL).
    Most likely causes:
    •Secure Sockets Layer (SSL) is enabled for the URL requested.
    •The page request was made over HTTP, but the server requires the request from a secure channel that uses HTTPS.
    Things you can try:
    •Browse to the URL over a secure channel by using the "https:" prefix instead of "http:".
    •If the Web site does not have an SSL certificate or should not require HTTPS, disable the setting.
    •Verify the SSL Settings in IIS Manager by connecting to the server, site, application or page and opening the SSL Settings feature.
    •Verify the configuration/system.webserver/security/access@sslFlags attribute at the server, site, application, or page level.
    Detailed Error Information:
    Module
    IIS Web Core
    Notification
    BeginRequest
    Handler
    ExtensionlessUrlHandler-Integrated-4.0
    Error Code
    0x80070005
    Requested URL
    http://servername:80/OperationsManager/
    Physical Path
    C:\Program Files\Microsoft System Center 2016\Operations Manager\WebConsole\MonitoringView\
    Logon Method
    Not yet determined
    Logon User
    Not yet determined
    Request Tracing Directory
    C:\inetpub\logs\FailedReqLogFiles

    -----------------------------------

    I changed the url to 

    https://servername:443/OperationsManager/

    error 

    <div class="mainContent" id="contentContainer"> <div align="left" id="moreInformationAlign" aria-labelledby="moreInformation"> <div class="infoBlock" id="infoBlockID">Your PC doesn’t trust this website’s security certificate.
    The hostname in the website’s security certificate differs from the website you are trying to visit.

    Error Code: DLG_FLAGS_INVALID_CA
    DLG_FLAGS_SEC_CERT_CN_INVALID

    </div> </div> </div>

  • Re: enable logging for internet explorer for an internal website.

    Oct 03, 2019 02:30 AM|Jalpa Panchal|LINK

    Hi,

    are you using the self-signed certificate? 

    to resolve 403.4 error please follow the below steps:

    1)open iis manager. select your site.

    2)click on the SSL setting from the middle pane.

    3)Clear the Require Secure Channel (SSL) checkbox, and then click apply.

    4)restart the iis server.

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: enable logging for internet explorer for an internal website.

    Oct 03, 2019 05:59 AM|arcolino|LINK

    this error was actually co-worker, testing out ssl settings. 

  • Re: enable logging for internet explorer for an internal website.

    Oct 03, 2019 06:04 AM|arcolino|LINK

    I tested a self signed cert but it did not load in i/e but it did load in chrome. I suspect an ssl cert is needed that has the required encryption, I work in a very secure environment so the cert not loading in i/e does not surprise me. I adjusted the ssl settings many times in iis, it did not work. I'm requesting an official cert from one of our agencies. 

  • Re: enable logging for internet explorer for an internal website.

    Oct 03, 2019 06:28 AM|Jalpa Panchal|LINK

    Could you share your iis site binding detail? and how you created a self-signed certificate? You could also try to move the self-signed certificate to the trusted root folder.

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: enable logging for internet explorer for an internal website.

    Nov 24, 2019 01:24 AM|arcolino|LINK

    sorry for the long delay, is there a log file or something I can check on the client web session to the iis server? 

    I thought on the iis server the "failed request tracking" would be the place but I enabled it a while back and checked the folder nothing is in there, any ideas? 

  • Re: enable logging for internet explorer for an internal website.

    Nov 24, 2019 04:23 AM|lextm|LINK

    arcolino

    I thought on the iis server the "failed request tracking" would be the place but I enabled it a while back and checked the folder nothing is in there, any ideas? 

    You have to enable FRT on site level, not merely create a rule. (If 500 neither shows in IIS log files, nor in FRT, then they come from another place, not likely this machine.)

    Lex Li
    Affordable IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: enable logging for internet explorer for an internal website.

    Nov 24, 2019 08:34 PM|arcolino|LINK

    when I said I enabled it, I enabled it at the iis server level on the default web site\configure failed request tracking checked enabled, and pointed it to the default location 

    the error that is coming up is kinda different not sure if it makes a difference it is now saying. 

    "This page isn’t working
    FQDN is currently unable to handle this request.
    HTTP ERROR 500"

  • Re: enable logging for internet explorer for an internal website.

    Nov 24, 2019 08:49 PM|lextm|LINK

    Combining all above, I think there isn't much to continue in this format, as clearly you need a more senior guy in your team to take a look, or you open a support case via http://support.microsoft.com to show Microsoft support guys the exact setup on your server.

    Lex Li
    Affordable IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: enable logging for internet explorer for an internal website.

    Nov 25, 2019 11:45 AM|arcolino|LINK

    lol, @ "clearly" in that case ""clearly" your an AH so dont be ridiculous! (got the name on the gossip chat then try come around on the back end to make a silly comment) cool interesting I've been positing on I.T. forums for over 10 years, never got that kind of response,  even when it was something more technical! plus its a forum open to all levels, and I can easily do any pointers given. you post for ideas on a fix!. in case you did not know this, its not mandatory for you to respond cool have a good 1!!