Cannot Create a 128-bit SSL Session with IIS 10.0.X.XRSS

2 replies

Last post Sep 11, 2019 02:42 AM by Jalpa Panchal

  • Cannot Create a 128-bit SSL Session with IIS 10.0.X.X

    Sep 10, 2019 01:10 PM|juancalbarran|LINK

    I am following these steps How To Set Up an HTTPS Service in IIS

    But I can not find the option to require 128 bits. The documentation talks about Directory Security Tab, however IIS 10 has not that option. I am using SSL settings and I can see the first check "Require SSL" but the second check "Require 128-bit encryption" is missing.

  • Re: Cannot Create a 128-bit SSL Session with IIS 10.0.X.X

    Sep 10, 2019 01:56 PM|lextm|LINK

    Lex Li
    https://lextudio.com
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Cannot Create a 128-bit SSL Session with IIS 10.0.X.X

    Sep 11, 2019 02:42 AM|Jalpa Panchal|LINK

    Hi,

    As Lexi said you could use appcmd or PowerShell to enable required 128-bit encryption.

    below is the command:

    using appcmd:

    appcmd.exe set config "sample1" -section:system.webServer/security/access /sslFlags:"Ssl128"  

    using PowerShell:

    Set-WebConfigurationProperty -pspath 'MACHINE/WEBROOT/APPHOST/sample1'  -filter "system.webServer/security/access" -name "sslFlags" -value "Ssl128"

    note: use your site name instead of  sample1.

    You can also enable using the iis configuration editor setting.

    1)Open the iis manager.

    2)select site from the connection pane.->select configuration editor from the middle pane.

    3)From the section dropdown menu select "system.webServer/security/access".

    4)in sslflag dropdown select ssl128.

    5)click on the apply.

    Regards,

    Jalpa

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.