We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

You don't currently have permission to access this folderRSS

17 replies

Last post Jul 19, 2019 02:20 AM by Jalpa Panchal

  • You don't currently have permission to access this folder

    Jul 16, 2019 12:15 AM|Seyoon Park|LINK

    Hello, I have a problem.
    When I use IIS, Log files save default path that %SystemDrive%\inetpub\logs\LogFiles.
    So, I move the path(%SystemDrive%\inetpub\logs\LogFiles) and see W3SVC1 folder.
    Double click this folder, I meet the 'You don't currently have permission to access this folder.'
    Sure, I can click Continue button and solve this problem.
    However, this folder makes continually. (If IIS site is running)
    For examples, When IIS makes new folder W3SVC2, I meet same message.
    But I don't want meet this message. When IIS makes new folder, I want to access this folder automatically not using script.
    I think that change IIS setting is solve this problem. But I don't know method.
    Please Help me~

  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 03:02 AM|Jalpa Panchal|LINK

    Hi,

    You face this issue because everyone does not have permission to access the system folder. could you please share which use you are trying to access log files? you can resolve this issue by giving an appropriate user permission to the LogFiles folder. you can also assign Everyone full control permission to the folder. 

    Regards,

    Jalpa

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 07:49 AM|Seyoon Park|LINK

    Thank you for your answer.

    But I want to apply forever.

    When website is updated, my IIS makes new log folder automatically.

    Then, I should try your solution again.

    But, I don't want to do again.

    I want to control that IIS makes folder option.

    So I don't have to your solution again.

    What can I do??

  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 08:24 AM|Jalpa Panchal|LINK

    if you do not want to assign permission manually every time then give permission to the log folder and set the advance setting to apply this setting to the subfolder and files. 

    You can refer below link if you want to use PowerShell scripting:

    https://superuser.com/questions/625975/iis-log-folder-permissions-not-being-inherited

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 08:34 AM|Seyoon Park|LINK

    I cannot find Permission Entry for LogFiles.

    My OS is Windows 10 Pro.

    I can open LogFiles Properties. 

    Please explicate detail how to go Permission Entry for Logfiles menu.


    +++

    I find Advanced button in LogFiles Properties.

    When click this button, I see IUSR, Full control, Inherited from- None, Applies to- This folder, subfolders and files

    But, Stop IIS and remove log folder 'W3SVC1' and Start IIS. Then, I visit my web site. 

    Then, IIS makes new log folder 'W3SVC1'.

    But, same problem occurred....

  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 08:57 AM|Jalpa Panchal|LINK

    Try to follow below steps:

    • go to the C:\inetpub\logs path.
    • Right, click on the LogFiles folder->select properties->in properties select the security tab->select advance.

    • In advance security setting you can find add and enable inheritance. select enable inheritance and then select add option to add user permission.

    • In the permission entry for log file tab select principal and give permission to the folder as shown in below image.

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:09 AM|Seyoon Park|LINK

    Thank you for your detail answer.

    I can find menu 'Permission Entry for LogFiles'.

    And I checked the all options. My IUSR option is same your answer.

    But same problem occurred.

    For the test, I stop IIS and remove log folder 'W3SVC1' and restart IIS.

    After, I visited my IIS web site. and IIS makes new log folder 'W3SVC1'.

    For example, properties of new log folder(W3SVC1) security tab

    You must have Read permissions to view the properties of this object. Click Advanced to continue.

    What can I do??

  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:14 AM|Jalpa Panchal|LINK

    could you explain what is your user type like administrator or another user? and for 'Permission Entry for LogFiles' you need to select add option.

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:17 AM|Seyoon Park|LINK

    My Owner is ---------------------------------------------

    And I clicked Add button and add IUSR.

  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:20 AM|Jalpa Panchal|LINK

    please remove machine name from your above post.

    Try to set everyone and administrator permission to the log folder.

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:25 AM|Seyoon Park|LINK

    What do you mean machin name? 

    Do you mean that Advanced Security Settings for LogFiles > Owner value is empty??

    or Set owner is everyone?

  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:27 AM|Jalpa Panchal|LINK

    no just edit above post and remove machine name for security purpose.

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:30 AM|Seyoon Park|LINK

    Thank you, I modified my post. 

    However, I cannot resolve original problem...

  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 09:32 AM|Jalpa Panchal|LINK

    If you still facing the same problem you can change the log file path to where you have permission to access file or folder like D drive or any other drive. 

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 16, 2019 11:53 PM|Seyoon Park|LINK

    Yes, I can change the log file path 'D:\logFiles'.

    But original problem is same.

    IIS always makes folder 'W3SVC1' in root Log File Directory.

    In my case, IIS makes new folder in 'D:\logFiles\W3SVC1..   

    When W3SVC1 folder is double-clicked, I meet the message 'You don't currently have permission to access this folder.'

    What I want is:

    I want to keep the permissions of the parent folder when IIS create the log folder Not using script.

    Is it impossible?

  • Re: You don't currently have permission to access this folder

    Jul 17, 2019 06:41 AM|Jalpa Panchal|LINK

    In my opinion, it's not possible. you need to write a script or you can do it manually applying permmsion to the folder or file permission.

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: You don't currently have permission to access this folder

    Jul 18, 2019 02:28 AM|Seyoon Park|LINK

    Although I did not solve it, thanks for you kind answers.

  • Re: You don't currently have permission to access this folder

    Jul 19, 2019 02:20 AM|Jalpa Panchal|LINK

    Could you share your log folder permission snapshot? 

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.