IIS6 site is not working in IIS7 onwardsRSS

3 replies

Last post May 31, 2019 09:11 AM by Jalpa Panchal

  • IIS6 site is not working in IIS7 onwards

    May 29, 2019 12:16 PM|digit007|LINK

    Hi All,

    I have created three pages in asp.net framework2.0 application. I have built the application and deployed to IIS6 & IIS7.5. I have got different button click result while accessing it from IIS6 & IIS7

    The sample application having three pages (Main.aspx, add.aspx & update.aspx). Landing page is Main.aspx page.

     

    Main.aspx: 

    Button click event to redirect a user to update.aspx.

    Have added form tag action method  <form id="form1" runat="server" action="add.aspx" method="post"> 

    add.aspx: having a text message “User is redirected to add page”.

    update.aspx: having a text message “User is redirected to update page”.

    I have deployed the project build code in IIS6 & IIS7. When a user clicks the Main page button then,

    IIS6 application- a user is redirected to update.aspx page .

    IIS7 application - a user is redirected to add.aspx page.

    Even I run the application in VS2005 & VS2017, then button click event behaves differently.

    Can you please let me know why it is behaving differently? What changes of IIS7 restring a user redirecting to update.aspx page.

  • Re: IIS6 site is not working in IIS7 onwards

    May 29, 2019 01:03 PM|lextm|LINK

    You probably should share a complete sample project. It sounds to me that your code is written improperly, so the actual behavior is undetermined (so no one guarantees the outcome). BTW, most ASP.NET developers are in the ASP.NET Forums, https://forums.asp.net/ not here.

    Lex Li
    IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: IIS6 site is not working in IIS7 onwards

    May 30, 2019 11:04 AM|digit007|LINK

    Thanks lextm.

    I have uploaded the sample code at github. Can you please download it and have a look,

    https://github.com/balaji2014/VS2005

    Thanks,

    Balaji

  • Re: IIS6 site is not working in IIS7 onwards

    May 31, 2019 09:11 AM|Jalpa Panchal|LINK

    Hi Balaji,

    As Lex Li suggests this issue is related to the .net framework. please post your question at .net forum https://forums.asp.net/.

    Thanks for understanding.

    Regards,

    Jalpa

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.