We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Windows 10 IIS - Permission Issues From External MachinesRSS

3 replies

Last post Feb 17, 2019 07:28 PM by lextm

  • Windows 10 IIS - Permission Issues From External Machines

    Feb 15, 2019 12:50 PM|Hercule|LINK

    Hi,

    I have created a simple website in IIS, just a index.htm file. I can browse the page locally using http://localhost but when I try and view the same page anywhere else on the network I get the following message:

    "You do not have permission to view this directory or page"

    Looking in the IIS logs I get the following error

    2019-02-15 10:23:10 192.168.0.10 GET / - 80 - 192.168.0.103 Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64;+rv:65.0)+Gecko/20100101+Firefox/65.0 - 403 2 5 48

    I am running as IUSR, and appear to have the following permissions at various steps:

    c:\  [IUSR:(RX)]

    c:\inetpub [IUSR:(RX)]

    c:\inetpub\wwwroot [IUSR:(RX)]

    c:\inetpub\wwwroot\index.htm [IUSR:(RX)]

    Any ideas what the problem is?

    Thanks

  • Re: Windows 10 IIS - Permission Issues From External Machines

    Feb 15, 2019 09:56 PM|lextm|LINK

    Lex Li
    Want to have a chat on the issues you meet? Book an appointment at https://buy.stripe.com/cN24ia0yi7sAdIA7sv
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Windows 10 IIS - Permission Issues From External Machines

    Feb 17, 2019 01:03 PM|Hercule|LINK

    Thanksi lextm,

    the link does not explain why the website works locally (presumably still using IUSR) but not remotely. I thnk there is something more in play here.

    Clearly I get some response from the website when connecting remotely, so it cannot be a firewall issue or another site sharing the same port, otherwise I would not get an entry in the log for the site.

  • Re: Windows 10 IIS - Permission Issues From External Machines

    Feb 17, 2019 07:28 PM|lextm|LINK

    Hercule

    the link does not explain why the website works locally (presumably still using IUSR) but not remotely. I thnk there is something more in play here.

    Did you follow that article to resolve the 403.2 issue recorded in the log entry? The "why" part can wait once you are sure the options in the article do solve the issue, or don't if you hit a more complicated case.

    Something "works locally" never has a guarantee to work elsewhere, as different machines are indeed different. Before guessing around (firewall, or other sites), you should focus on the most common causes. Otherwise, Microsoft won't waste time writing the article in the first place.

    Lex Li
    Want to have a chat on the issues you meet? Book an appointment at https://buy.stripe.com/cN24ia0yi7sAdIA7sv
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.