We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Problem in download app galleryRSS

1 reply

Last post Nov 19, 2018 03:29 AM by Brando Zhang

  • Problem in download app gallery

    Nov 17, 2018 06:34 PM|Siam|LINK

    when i click on the app gallery in the startup page, this following dialogue appear... moreover my internet connection is all ok..

    ***********

    Unable to download the Web Platform product list. Check your network connection and try again. If the problem persists, report the issue on the Web Platform Installer forum at: http://go.microsoft.com/fwlink/?LinkId=145244.
    Details:
    One or more errors occurred.

    'doctype' is an unexpected token. The expected token is 'DOCTYPE'. Line 1, position 3.

    System.AggregateException: One or more errors occurred. ---> System.Xml.XmlException: 'doctype' is an unexpected token. The expected token is 'DOCTYPE'. Line 1, position 3.
    at Microsoft.WebMatrix.Gallery.Wizard.GalleryWizardModel.Load()
    at System.Threading.Tasks.Task.InnerInvoke()
    at System.Threading.Tasks.Task.Execute()
    --- End of inner exception stack trace ---
    ---> (Inner Exception #0) System.Xml.XmlException: 'doctype' is an unexpected token. The expected token is 'DOCTYPE'. Line 1, position 3.
    at Microsoft.WebMatrix.Gallery.Wizard.GalleryWizardModel.Load()
    at System.Threading.Tasks.Task.InnerInvoke()
    at System.Threading.Tasks.Task.Execute()<---

  • Re: Problem in download app gallery

    Nov 19, 2018 03:29 AM|Brando Zhang|LINK

    Hi Siam,

    According to your description, I suggest you could firstly try to update your web installer platform to newest version.

    Download link:

    https://www.microsoft.com/web/downloads/platform.aspx 

    Then I suggest you could check your computer is behind proxy or behind firewalls.

    Behind Proxy If the computer is behind a proxy, ensure that the proxy settings for Windows® Internet Explorer® are set correctly and retry accessing the URL through Internet Explorer and then through Web PI
    Behind Firewalls In the case where third-party firewalls are installed on the computer, try disabling them before launching Web PI. You can also add exceptions for WebpiLauncher.exe and WebPlatformInstaller.exe to the firewall settings.If the issue is not resolved yet, It should be possible to fix the problem by following the steps described in How to troubleshoot network connectivity problems in Internet Explorer.

    Best Regards,

    Brando