We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

MS Access 2010 database can not openRSS

1 reply

Last post Nov 14, 2017 02:46 AM by Yuk Ding

  • MS Access 2010 database can not open

    Nov 13, 2017 03:02 AM|Ramjee|LINK

    I was using Classic ASP and  IIS 7.0 (Windows 2008).  I had to upgrade to IIS 8.5 (windows 2012). I am getting this consistent message. I have set maximum permission but no luck.

    Microsoft Access Database Engine error '80004005'

    The Microsoft Access database engine cannot open or write to the file 'Data.accdb'. It is already opened exclusively by another user, or you need permission to view and write its data.

    /DataUpdates/script1.asp, line 124

    strConn="Provider=Microsoft.ACE.OLEDB.12.0;Data Source=c:\temp\Data.accdb;Persist Security Info=False;"

    I had tried following on Windows 2010 Server

    * Installed IIS Compatibility

    * Installed ASP Role

    * Installed Microsoft Access Database Engine 2010 Redistributable from https://www.microsoft.com/en-ca/download/details.aspx?id=13255 (am i missing any adoptor)

    * Added "C:\temp\database.accdb" properties with full permission and full "app pool" permission

    * It worked on windows 2008 with "classic" app pool v2.0 (I had tried all settings and acccount)

    Could you please tell me what I am missing!!!

     

  • Re: MS Access 2010 database can not open

    Nov 14, 2017 02:46 AM|Yuk Ding|LINK

    Hi ramjee,

    You could try to disable the user profiler in application pool->advanced setting->load userproifler->false. In addition, please try to grant authenticated user and application pool identity the permission read/write permission to access c:\windows\temp not C:\temp\. Secondly, please ensure the connection string is correct without any issue.  If the steps above is not working, you could try to enable 32-bit application in application pool advanced setting.

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.