We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Ask for related article - HTTP Error 500.24 - Internal Server ErrorRSS

4 replies

Last post Nov 06, 2017 09:20 AM by Torviael

  • Ask for related article - HTTP Error 500.24 - Internal Server Error

    Oct 30, 2017 08:04 AM|Torviael|LINK

    Hello,

    Below is an error happened when use IIS to open a web page.

    'An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.'

    I use IIS Console as usual, where should I do next to disable 'client impersonation'?

    I am looking the web page can open with authenticating login in three modes :

    (a.Active Directory /

    b.Local Machine logon /

    c.Any Stanger Logon)

    Best Wishes,

    Tós

  • Rovastar Rovastar

    5495 Posts

    MVP

    Moderator

    Re: Ask for related article - HTTP Error 500.24 - Internal Server Error

    Oct 30, 2017 10:51 AM|Rovastar|LINK

    Have you tried running your app pool in classic rather than integrated pipeline mode?
    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: Ask for related article - HTTP Error 500.24 - Internal Server Error

    Oct 30, 2017 01:10 PM|lextm|LINK

    The "Classic ASP" subforum is for ASP only, not ASP.NET.

    For 500.24, you should refer to https://docs.microsoft.com/en-us/iis/application-frameworks/building-and-running-aspnet-applications/aspnet-20-breaking-changes-on-iis 

    Lex Li
    Want to have a chat on the issues you meet? Book an appointment at https://buy.stripe.com/cN24ia0yi7sAdIA7sv
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Ask for related article - HTTP Error 500.24 - Internal Server Error

    Oct 31, 2017 02:22 AM|Yuk Ding|LINK

    Hi Torviael,

    To disable the client impersonation, please go to IIS manager->server/site level->authentications->asp.net impersonation->disable. In addition, you could try to add validation attribute in system.webserver.

    <configuration>
       <system.webServer>
          <validation validateIntegratedModeConfiguration="true" />
       </system.webServer>
    </configuration>
    

    If the steps is not working, please compare the config file with the correct one.

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.
  • Re: Ask for related article - HTTP Error 500.24 - Internal Server Error

    Nov 06, 2017 09:20 AM|Torviael|LINK

    Finally I perform below action and the application pool have been solved.

    I. Backup the IIS entire Website data

    II. Adjust the web application pool to Classic ASP.net.

    III. Open the web page to broswer require web page successfully.

    Tós