SSL popup "Choose certificate" [Answered]RSS

3 replies

Last post Sep 06, 2017 02:25 PM by Frontier_frt

  • SSL popup "Choose certificate"

    Sep 05, 2017 09:11 PM|Frontier_frt|LINK

    Hello there,

    I would like to resolve an issue about my (new) website.

    After install all prerequisite (Generate & install a certificate on IIS8), it's still a weird popup displaying on some devices.

    After some tests, I can say it's limited (working with most of browsers (IE/Firefox/Chrome with a personal computer it's OK, IE on Windows Phone too)), but unconfortable, because as you see on the screenshot below, a popup can appeared on Android devices with Chrome (Qwant or Firefow it's working).

    May someone can help me to remove this popup?

    Here a screenshot from my Android device:
    http://hpics.li/5b9a3b8

    And the website which have the issue:
    https://www.echangelocation.com

  • Re: SSL popup "Choose certificate"

    Sep 06, 2017 06:38 AM|Ken Schaefer|LINK

    Did you select "Accept client certificates" in your SSL configuration on the website?

  • Re: SSL popup "Choose certificate"

    Sep 06, 2017 07:09 AM|Yuk Ding|LINK

    Hi Frontier_frt,

    So do you want to use certificate mapping authentication? Or you only need to use server certificate to achieve the ssl encryption? If you only need to use ssl, please adjust the certificate to require in IIS manager->site level->SSL setting->client certificates->ignore. Then it is enough for IIS Site SSL. The require or accept is used for certificate mapping authentication.That's why the IIS will prompt the popup for certificate. Even I use IE, the popup will still display.

    https://docs.microsoft.com/en-us/iis/configuration/system.webserver/security/authentication/clientcertificatemappingauthentication

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.
  • Re: SSL popup "Choose certificate"

    Sep 06, 2017 02:25 PM|Frontier_frt|LINK

    Ken Schaefer

    Did you select "Accept client certificates" in your SSL configuration on the website?

    Indeed, I had checked "Accept" on the SSL Setting. With our answer I did some search, and it seems the option is not linked with the https certificate.

    I move it to "Ignore", and "https" is working without popup now. Thanks to you. :)

    Yuk Ding

    Hi Frontier_frt,
    So do you want to
    ...
    Best Regards,
    Yuk Ding

    I tried our solution without success, I not seen the option in the list of authenticate panel. And next the question of Ken give me the answer :)

    Thanks to all! :)