Intermittent failiures "localhost refused to connect" [Answered]RSS

3 replies

Last post Aug 21, 2017 01:36 PM by Bunkermentality

  • Intermittent failiures "localhost refused to connect"

    Aug 17, 2017 03:13 PM|Bunkermentality|LINK

    I've just installed Webmatrix 3 ver 7.1.1934.0 onto my Win10 Home system, ver 10.0.15063. Using Webmatrix I successfully created a WordPress instance and copied one of my server-side WordPress pages onto this. All is good.

    But, after using Wordpress for a few minutes (how many minutes varies) everything stops and Google Chrome reports "localhost refused to connect" and "ERR_CONNECTION_REFUSED".

    After a while a refresh successfully brings things back to life.

    I'm very new to hosting WP on my local IIS ver 8 environment. Have I made some sort of basic error? Any advice would be most welcome.

  • Re: Intermittent failiures "localhost refused to connect"

    Aug 17, 2017 04:02 PM|Bunkermentality|LINK

    UPDATE. Once "localhost refused to connect" has been displayed F5 refreshes do not cause the page to re display. However as soon as WebMatrix is powered up for the WP website the fault disappears, even though I don't actually do anything with WebMatrix.

  • Re: Intermittent failiures "localhost refused to connect"

    Aug 18, 2017 06:26 AM|Yuk Ding|LINK

    Hi Bunkermentality,

    It is hard to say why webmatrix help fix this issue. If you meet the error message again, you could try to change the port number for the localhost url. I'm not sure whether it is a pure IIS issue. This link provide the solution for this issue:

    https://stackoverflow.com/questions/32190881/how-to-solve-err-connection-refused-when-trying-to-connect-to-localhost-running

    If this is still not working, you could consult the wordpress forum while I notice err_connection_refused is always displayed with wordpress.

    If the issue has been fix, it will appreciated if you could mark your reply as answer.

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.
  • Re: Intermittent failiures "localhost refused to connect"

    Aug 21, 2017 01:36 PM|Bunkermentality|LINK

    I have discovered that the connection error does not happen provided that WebMatrix remains active. I can't see why this should be the case but as a workaround it does the trick.