IIS Admin Service Won't Start after ransomewareRSS

2 replies

Last post Mar 07, 2017 09:41 AM by Yuk Ding

  • IIS Admin Service Won't Start after ransomeware

    Mar 06, 2017 05:16 PM|OULIWEI|LINK

    I was hit with a ransomware recently and after getting my system back my IIS Admin service will not start nor will my SMTP service.  The cause seems to be corrupt MachineKeys. Event Viewer gives:

    The IIS Admin Service service terminated with service-specific error 2148073478 (0x80090006).

    All searches point to corrupt c23... files.  I tried recovering these files from a backup with no luck.

    Might anyone have information how to reconfigure the IIS 6 compatibility components on Server 2008 machine without a complete IIS 7 reinstall?  I currently have HTML/ASP/PHP sites, Wordpress with MySQL sites, and DNN with MS SQL sites on the box, which all are working as they should with the exception of any IIS 6 component reliant services such as SMTP.

    Thank you in advance for any information or assistance

  • Re: IIS Admin Service Won't Start after ransomeware

    Mar 06, 2017 06:54 PM|lextm|LINK

    The best practice is to build another machine to replace this one (from your healthy backup obviously). Don't attempt to restore a corrupt machine, as you won't be able to know which are the broken pieces.

    Lex Li
    https://lextudio.com
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: IIS Admin Service Won't Start after ransomeware

    Mar 07, 2017 09:41 AM|Yuk Ding|LINK

    Hi OULIWEI,

    It seems to be related to the machine key.

    I think this link provide an effective solution to help you resolve the IIS admin service failed to start up error:

    https://blogs.msdn.microsoft.com/saurabh_singh/2007/08/01/iis-admin-service-fail-to-start/

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.