D:\Program Files (x86)\PHP\v7.0\php-cgi.exe - The FastCGI process exited unexpectedlyRSS

1 reply

Last post Feb 23, 2017 07:06 AM by Yuk Ding

  • D:\Program Files (x86)\PHP\v7.0\php-cgi.exe - The FastCGI process exited unexpectedly

    Feb 22, 2017 11:22 PM|victorcentero|LINK

    I have php website on azure in free tier.Everything works well except sqlite3 which requires the sqlite3 dll.


    I downloaded the dll and did what is said here:

    https://social.msdn.microsoft.com/Forums/en-US/42bf076d-883e-4818-8585-7bfedff1ff5c/how-to-enable-sqlite3-for-php-in-azure-websites?forum=windowsazurewebsitespreview

    Here is the full error:

    HTTP Error 500.0 - Internal Server Error
    D:\Program Files (x86)\PHP\v7.0\php-cgi.exe - The FastCGI process exited unexpectedly


    After that i get this error, obviously i do not have D:\Program Files (x86)\PHP\v7.0\php-cgi.exe in azure websites.

    I do not have that path mapped anywhere in my code !

    i have in the azure php error log.txt

    PHP Warning: PHP Startup: Unable to load dynamic library 'D:\home\site\wwwroot\bin\php_sqlite3.php' - The specified module could not be found.
    in Unknown on line 0

  • Re: D:\Program Files (x86)\PHP\v7.0\php-cgi.exe - The FastCGI process exited unexpectedly

    Feb 23, 2017 07:06 AM|Yuk Ding|LINK

    Hi victorcentero,

    It sounds like an PHP extension issue, try to add php_sqlite3.php to PHP.ini [ExtensionList].

    It could looks like:

    extension=php_sqlite3.php.dll

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.