Problems with CDO.MessageRSS

4 replies

Last post May 05, 2017 02:20 AM by carrzkiss

  • Problems with CDO.Message

    Feb 21, 2017 06:50 PM|Edson Junior|LINK

    We are trying to use the CDO.Message to send e-mail from a remote server, but when we try to open this link http://schemas.microsoft.com/cdo/configuration/smtpserver on webrowser we receive this message: The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

    I would like to know if this is normal or if there is any change on the service.

  • Re: Problems with CDO.Message

    Feb 22, 2017 03:06 AM|Yuk Ding|LINK

    Hi Edson,

    The CDO could be an old tecnology which is last updated in 2004 for exchange 2003. The CDO technology is still avalibale but the remote SMTP server service for CDO seems has stopped while it return 404 error. So maybe you could just test to send email locallly or change the parameter to another remote SMTP server service.

    Best Regards,

    Yuk Ding 

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.
  • Re: Problems with CDO.Message

    Mar 15, 2017 12:53 AM|carrzkiss|LINK

    These are not meant to be run in a web browser.
    They run code from behind the scenes.

    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/sendusing") = 2 'Send the message using the network (SMTP over the network)
    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpserver") = smtpserver
    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpserverport") = smtpport
    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpusessl") = smtpssl 'Use SSL for the connection (True or False)
    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpconnectiontimeout") = 60  
    ' If your server requires outgoing authentication uncomment the lines bleow and use a valid email address and password.
    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate") = 1 'basic (clear-text) authentication
    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/sendusername") =MainEmail
    myMail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/sendpassword") =MailPass


    I have been using it for years, and has never given me an issue.
    Wayne

    Knowledge is Power!
    Power is the sharing of Knowledge!

    CFF Knowledge Base

    Coding Source Share the Knowledge
  • Re: Problems with CDO.Message

    May 05, 2017 01:27 AM|nadnash|LINK

    hai. i'm also facing the same problem with my company email website. it have been few weeks since i have this issue. previously, my company used CDONT component, nobody don't even notice for few years. then when they asked me to upgrade something with the website, then i realized it's not working anymore. I try to do research and it said i need to use CDO.Message ,i've changed the script but still no luck. have you find anything from other websites Frown

  • Re: Problems with CDO.Message

    May 05, 2017 02:20 AM|carrzkiss|LINK

    Need errors...
    Are you getting any errors from the CDO?

    Knowledge is Power!
    Power is the sharing of Knowledge!

    CFF Knowledge Base

    Coding Source Share the Knowledge