Cannot connect via WebDav anymoreRSS

4 replies

Last post Feb 05, 2017 07:39 PM by krisvg

  • Cannot connect via WebDav anymore

    Jan 24, 2017 11:31 AM|bluborn|LINK

    Hello everybody,

    since the last week im trying to fix an issue with WebDAV. Is a little bit annoying.  After reading every single troubleshooting post (that I could find :D ), I have no idea what to do..

    I’m using WebDAV every single day. But from now – whiteout changes – it doesn’t work anymore.

    Every time I try to connect to the server I get the response “permissions denied”

    The oddity is, I already checked the NFTS permissions, the WebDAV permissions, tried it from different places – different programs like Dreamweaver, expression web.. nothing seems to work K

    after a few attempts, I finally made it to connect the WebDAV directory via UNC (Windows Explorer). So I finally thought the problem is gone.. but jeeeeh – the same error still occurs in every software I’d tested. After a few more hours of reading and testing, I finally got Dreamweaver to work (instead of windows auth. Dreamweaver uses basic auth..).

    last but not least, Microsoft expression web 4 want work anymore -  same error occurs “permissions denied”.

    So.. what have I already done?

    Sorry for my bad English. Maybe it’s possible to write in German?

    Thanks for feedback!

  • Re: Cannot connect via WebDav anymore

    Jan 25, 2017 02:38 AM|Yuk Ding|LINK

    Hi bluborn,

    Is there any change in your server last week? Could any group policy or firewall, anti-virus has blocked the port number?

    Besides, is there any error message in event viewer or log?You may need to check whether the webclient service is running correctly in services.msc.

    Please check whether you have added the user to both authorization rule and WEBDAV authorization rule.

    You could also try to set the website->basic setting->connect as->specific user(your login user).

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.
  • Re: Cannot connect via WebDav anymore

    Jan 25, 2017 09:11 AM|bluborn|LINK

    Good morning Yuk,

    thanks for your feedback!!

    Sadly, there was no change at all. I already checkt the Firewall/Ports/http Headers via Wireshark – Everything’s seems ok, nothings seems to be cropped. Everything else on the server runs whiteout problems (multiple websites, SQL instances…). The only information about the login in the Windows Event Log looks like

    Failure Information:

                    Failure Reason:                     An Error occured during Logon.

                    Status:                                    0xC000006D

                    Sub Status:                            0x0

    ----------------

    Detailed Authentication Information:

                    Logon Process:                    

                    Authentication Package:     NTLM

                    Transited Services:               -

                    Package Name (NTLM only):             -

                    Key Length:                           0

     

    Whenever i try to connect over Microsoft Expression Web i get the response „permissions denied“.

    I also checkt the user permissions under „Authorization Rules“ (all Users), WebDAV (Role Administrators and my User (whit and without Hostname like server\UserName)).

    Connecting with a Admin User instead oft he IUSER doesn’t work also.

    I have no idea what to do. ¯\_(ツ)_/¯

    -----

    edit: also tried this solution: https://support.microsoft.com/de-de/help/896861/you-receive-error-401.1-when-you-browse-a-web-site-that-uses-integrated-authentication-and-is-hosted-on-iis-5.1-or-a-later-version

    btw its a virtual windows server 2012 r2

    -----

    here the full log

    - System
    <div>
    - Provider
    <div>
    [ Name] Microsoft-Windows-Security-Auditing
    [ Guid] {54849625-5478-4994-A5BA-3E3B0328C30D}
    </div>
    EventID 4625
    Version 0
    Level 0
    Task 12544
    Opcode 0
    Keywords 0x8010000000000000
    - TimeCreated
    <div>
    [ SystemTime] 2017-01-25T12:04:52.529039800Z
    </div>
    EventRecordID 746029
    Correlation
    - Execution
    <div>
    [ ProcessID] 488
    [ ThreadID] 508
    </div>
    Channel Security
    Computer ServerName
    Security
    </div>
    - EventData
    <div>
    SubjectUserSid S-1-0-0
    SubjectUserName -
    SubjectDomainName -
    SubjectLogonId 0x0
    TargetUserSid S-1-0-0
    TargetUserName UserName
    TargetDomainName ServerName
    Status 0xc000006d
    FailureReason %%2304
    SubStatus 0x0
    LogonType 3
    LogonProcessName
    AuthenticationPackageName NTLM
    WorkstationName ServerName
    TransmittedServices -
    LmPackageName -
    KeyLength 0
    ProcessId 0x0
    ProcessName -
    IpAddress -
    IpPort -
    </div>
  • Re: Cannot connect via WebDav anymore

    Jan 26, 2017 09:42 AM|bluborn|LINK

    So I’m trying and trying and trying.. idk why, but as long the anonymous authentication is activated there is no possibility to login in via WebDAV and Expression Web. To localize the problem, i deactivated the ano auth. And baam Expression Web want to know my credentials.

    (after that i get the error above - An Error occured during Logon. Status:      0xC000006D)

    But as long the ano. Auth. Is deactivated, nobody can view the website without any credentials.
    Actually this is no option :| looking forward for some solution

  • Re: Cannot connect via WebDav anymore

    Feb 05, 2017 07:39 PM|krisvg|LINK

    Hi bluborn,

    I'm not a WebAdmin or anything but as far as I know it doesn't make any sense to have "anonymous" and another protocol enabled for authentication. The anonymous access will always succeed and you'll never be authenticated (hence probably the access denied messages  you're experiencing). Are you sure you always had both these authentication methods enabled (i.e. when your WebDAV authentication still functioned)?

    BTW: the S-1-0-0 account stands for null, i.e. anonymous logon, which is exactly what you'd expect if you set anonymous authentication enabled on your site.