How to change ARR configRSS

3 replies

Last post Nov 11, 2016 09:07 AM by Yuk Ding

  • How to change ARR config

    Nov 10, 2016 10:17 AM|afatboy|LINK

    on same applicaion server is 192.168.40.88:8088.

    the compnay public ARR Server is 192.168.40.10, the ARR master create ARR Farm [add my application www.mydomain.com(AAA->192.168.40.10)]  to my application Server 192.168.40.88:8088.

    then, i visit www.mydomain.com can show my application,but the content Url is start by http://www.mydomain.com:8088/XXXXX.

    now i install ARR in my location machine[192.168.30.33],create arr farm www.b.com  [host file create 127.0.0.1  www.b.com], add the same server 192.168.40.88:8088. and i view www.b.com , the content url is correct, http://www.b.com/XXXX, not 8088 port.

    why? which config could influence this prot?

  • Re: How to change ARR config

    Nov 11, 2016 03:42 AM|Yuk Ding|LINK

    Hi afatboy,

    Are you using ARR as load balancer?

    ARR loadbalance will only relay the request to the different server and send response to the ARR server . Then the URL will show the port of the server. When you build ARR on the server  192.168.40.10:8088, the loadbalance algorithm will route the response to the 8080 server .   So when you build the server farm on the machine 192.168.30.33. The response will be routed to your location machine and use the default port number 80. The web browser will hide 80 port by default. Maybe you could try to configure the ARR port in Create server farm->advanced setting->application request routing

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.
  • Re: How to change ARR config

    Nov 11, 2016 08:39 AM|afatboy|LINK

    thanks for Yuk Ding

    My problem has been solved,the reason is that i get Server prot by Request Server_Port, when i am use Request Http_Host, there is nothing 

    Therefore,ARR can not resolve prot, just as at nginx:

    proxy_set_header       Host    $host:80;

  • Re: How to change ARR config

    Nov 11, 2016 09:07 AM|Yuk Ding|LINK

    Hi afatboy,

    I'm glad that your problem has been resolved.

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.