We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Failed to run operation 'RunRemote'. Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' on server 'abc.xyz.com'.RSS

4 replies

Last post May 10, 2016 07:40 AM by Jean Sun

  • Failed to run operation 'RunRemote'. Failed to run method 'Microsoft.Web.Farm.GetInstalledProduc...

    May 02, 2016 07:55 AM|RajuJain33|LINK

    Hi,

    We are getting this error in every 6-8 hours on our Web farm, application and platform provisioning both has been disabled.

    Failed to run operation 'RunRemote'.  Failed to run method 'Microsoft.Web.Farm.GetInstalledProductsRemoteMethod' on server 'abc.xyz.com'.  Remote agent (URL http://abc.xyz.com:8173/WEBFARMAGENTSERVICE/) could not be contacted.  Make sure the remote agent service is installed and started on the target computer.  Unable to connect to the remote server.  No connection could be made because the target machine actively refused it x.x.x.x:8173.  Remote agent (URL http://abc.xyz.com:8173/WEBFARMAGENTSERVICE/) could not be contacted.  Make sure the remote agent service is installed and started on the target computer.  Unable to connect to the remote server.  No connection could be made because the target machine actively refused it x.x.x.x:8173.

    I have checked the Apphost.config , application and platform provisioning are in disabled in config as well. I don't why we are getting this error. Please find the below apphost config entry

    <webFarm name="name" enabled="true" adminUserName="username" adminPassword="somepassword" primaryServer="primaryservername">
    <server address="primaryservername" enabled="true" />
    <server address="secondaryservername" enabled="true" />
    <platformProvision stopOnInstall="false" periodicSync="00:05:00" syncPlatformFromPrimary="false" />
    <applicationProvision offlineWhileSync="false" syncWebServerFromPrimary="false" periodicSync="00:00:30">
    <clear />
    </applicationProvision>
    <applicationRequestRouting>
    <affinity useCookie="false" ignoreSubDomainClientAffinity="true" />
    <loadBalancing algorithm="LeastRequests" />
    <healthCheck url="healthcheckurl" interval="00:00:30" timeout="00:00:30" responseMatch="Page Successfully Loaded" />
    <protocol timeout="00:01:00" />
    </applicationRequestRouting>
    </webFarm>

    RJ
  • Re: Failed to run operation 'RunRemote'. Failed to run method 'Microsoft.Web.Farm.GetInstalledPr...

    May 03, 2016 05:47 AM|Jean Sun|LINK

    Hi,

    Have you checked your firewall? Perhaps it is blocked by your firewall.

    Best Regards,

    Jean

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: Failed to run operation 'RunRemote'. Failed to run method 'Microsoft.Web.Farm.GetInstalledPr...

    May 03, 2016 05:55 AM|RajuJain33|LINK

    Yes, we have checked the firewall, firewall are in disabled mode for all the servers.  

    RJ
  • Re: Failed to run operation 'RunRemote'. Failed to run method 'Microsoft.Web.Farm.GetInstalledPr...

    May 03, 2016 05:57 AM|RajuJain33|LINK

    Jean Sun

    Hi,

    Have you checked your firewall? Perhaps it is blocked by your firewall.

    Best Regards,

    Jean

    Yes, we have checked the firewall, firewall are in disabled mode for all the servers.  

    RJ
  • Re: Failed to run operation 'RunRemote'. Failed to run method 'Microsoft.Web.Farm.GetInstalledPr...

    May 10, 2016 07:40 AM|Jean Sun|LINK

    Hi,

    This error should be related to network settings.

    Perhaps the network is not stable. So this error occur every 6-8 hours.

    Best Regards,

    Jean

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.