We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

RPC error [Answered]RSS

3 replies

Last post Jan 07, 2016 10:02 PM by Rovastar

  • RPC error

    Dec 16, 2015 07:34 AM|IIS_JE|LINK

    I have an RDS server which sits behind an IIS ARR 3 server. I'm running Windows Server 2012 R2 on all my servers and I am running IIS ARR 3.01.1952 and also have the URL Rewriting Module 2 (version 7.2.1952) installed. I also have Exchange behind the IIS ARR server.

    I have been accessing my RDS and Exchange server via the IIS ARR server from the internet for weeks now with no issues. Everything works such as: OWA, Autodiscover, ActiveSync and accessing RemoteApps/Desktop from a browser.

    Yesterday I installed the Microsoft Android Remote Desktop Client on my phone and couldn't get past adding the Remote Resources on my phone while connected to the internet. When I connected my phone to the internal Wifi (so I wouldn't be accessing RDS via IIS ARR) I could successfully add the Remote Reources on my phone and could access them no problem. So as a test I changed the firewall rule to temporarily allow my phone to access the RDS Remote Resources directly (therefore bypassing the IIS ARR server) and I could (again) access the RDS servers Remote Resources with no issues. Once I changed the firewall rule to point to the IIS ARR server again the Remote Resources on my Android phone failed when I tried to launch them in the Android Remote Desktop Client.

    In the IIS logs on the IIS ARR server I can see this error:

    2015-12-16 11:31:20 192.168.0.87 RPC_IN_DATA /rpc/rpcproxy.dll localhost:3388 443 - 185.3.54.12 MSRPC - 404 0 2 89
    2015-12-16 11:31:20 192.168.0.87 RPC_OUT_DATA /rpc/rpcproxy.dll localhost:3388 443 - 185.3.54.12 MSRPC - 404 0 64 87

    I have set the Request Filtering filter limit to 2147483648 but this didn't help. I followed the following article when setting up the IIS ARR server:

    http://blogs.technet.com/b/exchange/archive/2013/07/19/reverse-proxy-for-exchange-server-2013-using-iis-arr-part-1.aspx

    Can someone help please as I am out of ideas! Everything works using the IIS ARR server except the Android Remote Resources using MS Remote Desktop.

    Thank you!

  • Re: RPC error

    Dec 19, 2015 02:01 AM|sw-ing|LINK

    You could try to post the question to Exchange forums

    https://social.technet.microsoft.com/Forums/office/en-US/home?category=exchangeserver

    with regards,

    swing

  • Re: RPC error

    Jan 07, 2016 05:18 PM|DJBenson|LINK

    I'm getting exactly the same error when trying to use ARR with RDS.

    I've been trying for days to get them to play nicely but it's only now I've realised that it's the rewrite module that's causing the RPC error with RD Gateway.

    To recreate the problem, I did the following;

    • In a clean VM I installed the RD Gateway role
    • I configured my firewall to point at the RDG VM and could connect successfully via the internet
    • I then installed ARR and the rewrite module - immediately my end point failed with a 503 RPC error
    • Using add/remove programs I removed the rewrite module (leaving ARR in situ) and the endpoint recovered

    There seems to be an issue with RPC and the rewrite module under certain circumstances.

  • Rovastar Rovastar

    5495 Posts

    MVP

    Moderator

    Re: RPC error

    Jan 07, 2016 10:02 PM|Rovastar|LINK

    What urlrewrite rules were you using?
    Troubleshoot IIS in style
    https://www.leansentry.com/