"No input file specified." RSS

5 replies

Last post Nov 04, 2015 08:56 AM by Jan Reilink

  • "No input file specified."

    Oct 15, 2015 05:46 PM|jgwinner|LINK

    I installed Wordpress with the Web platform installer.

    We occasionally get an error when going to any web page that says "No input file specified." or a 404 error. IF the user hits 'refresh' the web page will usually promptly show up. The URL's are correct.

    I thought it was a Wordpress issue with an authentication plugin, but I tried different wordpress modules for authentication and got the same error.

    I followed the instructions to check both:

    ; commented out doc_root per:
    ; http://us2.php.net/install.windows
    ; doc_root =
    
    ; as well as checking this: 
    ; **You CAN safely turn this off for IIS, in fact, you MUST.** ; http://php.net/cgi.force-redirect
    cgi.force_redirect = 0
    

    I restarted the World Wide Web publishing service from both IIS 7 and from the Services snapin, but we still get the error.

    Doing a web page refresh always seems to work.

    I checked, and it does appear PHP is running with FastCGI, so I figured I'd open a question here. I checked the mappings and they all seem correct.

    Any other ideas??

    php wordpress

  • Re: "No input file specified."

    Oct 15, 2015 06:34 PM|jgwinner|LINK

    I also found this note, but it did not work!

    Another place to check is the Request Restrictions for the FastCGI Module Handler Mapping in IIS. You must check the box next to "Invoke handler only if request is mapped to:" and toggle on the "file" option. By default, when you setup the FastCGI Module to run as PHP, this option defaults to files and folders and so IIS thinks .php is a folder and tries to find a web.config file, which it doesn't find and then spits out the hated "No input specified" message.

    From http://www.iis-aid.com/articles/trouble_shooting/no_input_file_specified?page=1

    php wordpress

  • Re: "No input file specified."

    Oct 15, 2015 08:35 PM|jgwinner|LINK

    I just read a note that it may be related to disk deduplication.

    The thread is here:

    https://kickthatcomputer.wordpress.com/2013/12/22/no-input-file-specified-windows-server-2012-dedupe-on-iis-with-php/

    So far, it still doesn't help, although I'm going to setup the PHP folders to not dupe either.

    == John ==

    php wordpress

  • Re: "No input file specified."

    Oct 16, 2015 02:47 AM|Fei Han - MSFT|LINK

    Hi jgwinner,

    jgwinner

    We occasionally get an error when going to any web page that says "No input file specified." or a 404 error.

    Please refer to the following links that discussed about this issue.

    http://www.thehotlick.com/2/post/2013/01/wordpress-site-giving-no-input-file-specified-error.html

    http://stackoverflow.com/questions/6275755/no-input-file-specified-error-in-wordpress

    Best Regards,

    Fei Han

    php wordpress

  • Re: "No input file specified."

    Oct 16, 2015 03:06 AM|jgwinner|LINK

    Thanks! But those links don't seemingly apply. I'm on IIS, I don't have an .htaccess and those lines aren't in it (as it doesn't exist).

    I'm not using plesk either (the other solution in your links).

    == John ==

    php wordpress

  • Re: "No input file specified."

    Nov 04, 2015 08:56 AM|Jan Reilink|LINK

    A "No input file specified" error usually means Request Restrictions aren't configured properly. Set the "Invoke handler only if request is mapped to:" to "File":

    https://www.saotn.org/php-iis-no-input-file-specified/

    Also, make sure your rewrites for WordPress (Permalinks) are set up correctly.

    php wordpress

    Vevida: https://vevida.com
    Sysadmins of the North: http://www.saotn.org