We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

how to update php [Answered]RSS

5 replies

Last post May 22, 2015 11:09 AM by mike4309

  • how to update php

    May 14, 2015 04:24 AM|mike4309|LINK

    kaspersky detected vulnerability in my php so i downloaded newer version from http://php.net/downloads.php
    but when i change the folder name from  
    c:\program files (x86)\IIS Express\v5.3
    to
    c:\program files (x86)\IIS Express\v5.6.8   
    php files in webmatrix don't work anymore.
    Where is that path written so i can change it ?

    also, why isn't webPI offering the newest version of php, it only gives me option to install v5.6 ? which would be of no help bcz kaspersky says that all PHP 5.6 versions earlier than 5.6.7 have that vulnerability.

  • Re: how to update php

    May 14, 2015 10:51 PM|Pengzhen Song - MSFT|LINK

    Hi,

    To configure php for iis express, we can modify the two section:

    <fastCgi> 
        <application fullPath="C:\Program Files (x86)\iis express\PHP\v5.6\php-cgi.exe" monitorChangesTo="php.ini" activityTimeout="600" requestTimeout="600" instanceMaxRequests="10000">
          <environmentVariables>
            <environmentVariable name="PHP_FCGI_MAX_REQUESTS" value="10000" />
            <environmentVariable name="PHPRC" value="C:\\Program Files (x86)\iis express\PHP\v5.6" />
          </environmentVariables>
        </application>
    </fastCgi>

    And

    <location path="PHPSite"> 
    <system.webServer> 
           <handlers> 
                   <remove name="PHP via FastCGI" />
                   <remove name="New_PHP" />
                   <!-- add handler -->
                   <add name="New_PHP" path="*.php" verb="*" modules="FastCgiModule"  scriptProcessor="C:\Program Files (x86)\iis express\PHP\v5.6\php-cgi.exe" resourceType="File" requireAccess="Script" allowPathInfo="true"  responseBufferLimit="256" />
          </handlers>
    </system.webServer> 
    </location>

    And then, we can run phpinfo.php to test the php version.

    For more information, please refer to the document:

    https://www.saotn.org/custom-php-fastcgi-iis-express-webmatrix/

    http://forums.iis.net/t/1214344.aspx?Web+Matrix+and+PHP+5+5

    We are trying to better understand customer views on social support experience. Click HERE to participate the survey.
    Thanks!
  • Re: how to update php

    May 17, 2015 04:45 AM|mike4309|LINK

    i changed those parts in the   applicationhost.config   file in    Documents\IISExpress8\config    but it still don't work.
    I get:

    HTTP Error 500.0 - Internal Server Error
    The page cannot be displayed because an internal server error has occurred.
    Most likely causes:

        IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
        IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
        IIS was not able to process configuration for the Web site or application.
        The authenticated user does not have permission to use this DLL.
        The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.

    Things you can try:

        Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
        Check the event logs to see if any additional information was logged.
        Verify the permissions for the DLL.
        Install the .NET Extensibility feature if the request is mapped to a managed handler.
        Check the failed request tracing logs for additional information about this error. For more information, click here.

    Detailed Error Information:
    Module       FastCgiModule
    Notification       ExecuteRequestHandler
    Handler       PHP53_via_FastCGI
    Error Code       0x80070585
    Requested URL       http://localhost:47856/PHPPage.php


    More Information:
    This error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error.

    View more information »

    Microsoft Knowledge Base Articles:

        294807

  • Re: how to update php

    May 20, 2015 08:06 AM|Pengzhen Song - MSFT|LINK

    Hi,

    Please make sure the iis application pool identity account has enough permission for the folder C:\\Program Files (x86)\iis express\PHP\v5.6

    We are trying to better understand customer views on social support experience. Click HERE to participate the survey.
    Thanks!
  • Re: how to update php

    May 21, 2015 06:25 AM|mike4309|LINK

    how do i do that ?

    ins't the problem that it the handler is still   PHP53_via_FastCGi:

    Detailed Error Information:
    Module       FastCgiModule
    Notification       ExecuteRequestHandler
    Handler       PHP53_via_FastCGI

  • Re: how to update php

    May 22, 2015 11:09 AM|mike4309|LINK

    what if i just search for   v5.3   in the    applicationhost.config    file in    Documents\IISExpress8\config    and change it with    v5.6     
    It's in 3 places and seems to work fine after that.
    phpInfo() shows    PHP Version     5.6.9