We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

PHP requests and timeoutsRSS

3 replies

Last post May 04, 2015 07:29 PM by LordInfidel

  • PHP requests and timeouts

    Mar 13, 2015 06:46 PM|beacon_muzzo|LINK

    I have a website that I need to set low execution times for.  Some of the php pages on the site run for longer than 10 minutes and I'd like to have them timeout at 2 minutes.

    - I've set max_execution_time to 120 seconds via the php.ini, verified the setting took via phpinfo file I created.
    - set the CGI setting from 15 minutes to 2 minutes
    - set the "Request Timeout" setting under the FastCGI application settings for the PHP version I am running to 120 seconds

    Even after an IIS reset none of these settings seem to cause a request to timeout in with the values I've set. 

    Any tips? 


  • Re: PHP requests and timeouts

    Mar 15, 2015 11:06 PM|Pengzhen Song - MSFT|LINK


    I find the article say that This function has no effect when PHP is running in safe mode. There is no workaround other than turning off safe mode or changing the time limit    in the php.ini.

    For more information, please refer to the document:


    We are trying to better understand customer views on social support experience. Click HERE to participate the survey.
  • Re: PHP requests and timeouts

    Mar 16, 2015 02:55 PM|beacon_muzzo|LINK


    We do not have PHP in safe mode so this definitely isn't the issue.

    Anything else we can look at?

  • Re: PHP requests and timeouts

    May 04, 2015 07:29 PM|LordInfidel|LINK

    Don't forget the app pool settings as well

    You have 3 areas; PHP, FastCGI and IIS (app pool and site).