AppCmd gives error when the product is run silently [Answered]RSS

3 replies

Last post May 01, 2014 04:18 PM by AarohiP

  • AppCmd gives error when the product is run silently

    Apr 24, 2014 02:05 PM|AarohiP|LINK

    Hello ,

    I am using AppCmd 

    appcmd set config "Default Web Site/Test/App1" -section:system.webServer/security/authentication/anonymousAuthentication /enabled:"True" /commit:apphost

    to enable anonymous authentication for that particular application. This is being called through a Custom Action in my installer. It works fine if i run my installer using GUI method. But when run using commandline/silently it gives me below error:

    CustomAction APPHOST_ANONYMOUSAUTH returned actual error code 1168 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (58:24) [15:43:39:389]: Product:  -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action APPHOST_ANONYMOUSAUTH, location: C:\Windows\SysWOW64\, command: inetsrv\appcmd set config "Default Web Site/Test/App1" -section:system.webServer/security/authentication/anonymousAuthentication /enabled:"True" /commit:apphost

    Could someone please help out?

    I already checked the website name, its Default Web Site. Also checked the WWW and WAS services, looks good.

    iis IISAPPCMD

  • Re: AppCmd gives error when the product is run silently

    Apr 25, 2014 02:42 AM|Pengzhen Song - MSFT|LINK

    Hi,

    It maybe location issue. You can set the appcmd.exe path like this "[System64Folder]inetsrv\appcmd.exe set config ...

    For more information, you can refer to the similar discussion:

    http://stackoverflow.com/questions/10028598/wix-customaction-execommand-failing

    Hope it can help you.

    iis IISAPPCMD

    We are trying to better understand customer views on social support experience. Click HERE to participate the survey.
    Thanks!
  • Re: AppCmd gives error when the product is run silently

    Apr 25, 2014 02:01 PM|AarohiP|LINK

    Thanks , but its already pointing to this location Frown

    iis IISAPPCMD

  • Re: AppCmd gives error when the product is run silently

    May 01, 2014 04:18 PM|AarohiP|LINK

    Thanks ... I resolved this. I was using wrong website name in silent install :(

    iis IISAPPCMD