Publishing website in IIS 6.1 with CSS and JS [Answered]RSS

3 replies

Last post Dec 16, 2013 03:48 AM by gbranston

  • Publishing website in IIS 6.1 with CSS and JS

    Dec 13, 2013 10:56 AM|gbranston|LINK

    Hi

    Thanks for any help in advance

    I've developed a very simple website using Dreamweaver and a downloaded template, its nothing fancy just a site which has a load of admin links on it.

    It uses both CSS and JS files to alter the view and navigate on the page, basically it has the main index.html which is one very wide page, using the CSS/JS you can only see the first menu icons and then it scrolls to the right when you click a menu item, i've edited this to be much more simple but the template is.. http://www.templatemo.com/preview/templatemo_359_singular

    Now this works absolutely fine on both my own PC and the localhost of the server i am trying to publish it from

    However when i try to access it externally i can see the index.html and it has loaded all of the CSS files (can tell by the formatting) but the browsing/sliding to the other pages doesn't work, you just scroll, i can only assume this is due to the JS not loading for some reason, i've looked at the permissions of the root folder but from what i can see it all looks ok.

    Can anybody offer any advice? i'm pretty sure i'm missing a simple step but i'm now banging my head against a brick wall!

     

    Thanks again in advance

  • Rovastar Rovastar

    5428 Posts

    MVP

    Moderator

    Re: Publishing website in IIS 6.1 with CSS and JS

    Dec 13, 2013 11:35 AM|Rovastar|LINK

    Use Fiddler, firebug, etc to see what has loaded and what has not.

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: Publishing website in IIS 6.1 with CSS and JS

    Dec 16, 2013 03:34 AM|gbranston|LINK

    Rovastar

    Use Fiddler, firebug, etc to see what has loaded and what has not.

    Hi, so intended to try Firebug with firefox first...but the page loads absolutely fine with firefox, can only assume that its an issue with IE, using fiddler2 with IE everything appears to be loading correctly, in short if its used in firefox, perfect! if not, rubbish!

    Any thoughts?

    Thanks


     

  • Re: Publishing website in IIS 6.1 with CSS and JS

    Dec 16, 2013 03:48 AM|gbranston|LINK