IIS7 503 error service unavailableRSS

20 replies

Last post Nov 23, 2016 06:20 PM by PaulScott

  • IIS7 503 error service unavailable

    Jan 06, 2013 06:29 PM|APT513|LINK

    We are using 2008R2 Standard fully updated. We have IIS 7.0

    If we browse to ip/localhost or localhost we get a 503 service unavailable error.

    We dabbled with exchange 2010 a few years ago but eventually decided to go with hosted exchange. We eventually uninstalled it through control panel.

    Fast forward to this weekend, we wanted to start using webapps through RDS. The system requires IIS to work but it isnt. We get the 503 service unavailable error.

    The DefaultAppPool stops after the 5 rapid failures. If we increase it to 15, it stops after 15. We did have 3 orphaned apps related to exchange in the default pool. We created a pool called DeleteMe and moved them there (was easier than removing them for testing) We thought the error message in event viewer about "The Module DLL D:\Program Files\MicrosoftExchange Server\V14\Bin\kerbauth.dll failed to load" was the issue so we removed the offending code from the applicationHost.config file. That didnt solve it so we used appcmd to remove the orphaned programs. That didnt work either.

    We made sure there wasnt a reservation for :80 in http acl's.

    We make sure profile load was false

    We checked as much as we could find on the internet to no avail

    I think the issue has to do with the "The Module DLL D:\Program Files\MicrosoftExchange Server\V14\Bin\kerbauth.dll failed to load" error in event viewer. We removed it from the config file, and IIS apps. It must get called from somewhere else as well.

    Im not sure what else to do. Any help would be appreciated.

  • Re: IIS7 503 error service unavailable

    Jan 07, 2013 08:45 PM|APT513|LINK

    Nobody?

  • Re: IIS7 503 error service unavailable

    Jan 08, 2013 08:52 AM|murtaza_t|LINK

    Hello,

    I am not sure if this problem has to do anything with IIS however in order to provide you some help, I will request you to paste the exact error.

    From what you have mentioned I see that there is a missing "\" after Microsoft, in your path. Also few people in internet have said that moving the .dll file on C: drive with the same path have fixed their problem.

    Please Mark the post as Answer if it has helped you.
    Regards,
    Murtaza
  • Rovastar Rovastar

    5482 Posts

    MVP

    Moderator

    Re: IIS7 503 error service unavailable

    Jan 08, 2013 11:35 AM|Rovastar|LINK

    Maybe it is an rogue ISAPI filter causing this? *shrug*

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: IIS7 503 error service unavailable

    Jan 08, 2013 06:50 PM|APT513|LINK

    Exact error:

    Log Name:      Application
    Source:        Microsoft-Windows-IIS-W3SVC-WP
    Date:          1/6/2013 5:40:54 PM
    Event ID:      2280
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SERVER.local
    Description:
    The Module DLL D:\Program Files\MicrosoftExchange Server\V14\Bin\kerbauth.dll failed to load.  The data is the error.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-IIS-W3SVC-WP" Guid="{670080D9-742A-4187-8D16-41143D1290BD}" EventSourceName="W3SVC-WP" />
        <EventID Qualifiers="49152">2280</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-01-06T22:40:54.000000000Z" />
        <EventRecordID>1090917</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>Application</Channel>
        <Computer>SERVER.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="ModuleDll">D:\Program Files\MicrosoftExchange Server\V14\Bin\kerbauth.dll</Data>
        <Binary>7E000000</Binary>
      </EventData>
    </Event>

  • Re: IIS7 503 error service unavailable

    Jan 09, 2013 02:06 AM|Chen Yu - MSFT|LINK

    Hi,

    From your error message, please check your dll path which had mentioned by @murtaza_t, if you install exchange in default path, its path should be like this, C:\Program Files\Microsoft\Exchange Server\v14\Bin\kerbauth.dll.

    If that path is not correct, you could change it in C:\Windows\System32\inetsrv\config\applicationHost.config. You could follow below article to finish it. http://itproafrica.com/technology/exchange/exchange-2010-wrong-path-for-kerbauth-dll-in-iis-config/

    Best Regards,

    Please mark the replies as answers if they help or unmark if not.
    Feedback to us



  • Re: IIS7 503 error service unavailable

    Jan 09, 2013 07:49 AM|APT513|LINK

    Exchange isnt installed anymore.

    I already removed the line from the applicationhost.configfile. Ran iisreset -restart and rebooted the server a few time since then.

    Where else can it be?

  • Re: IIS7 503 error service unavailable

    Jan 10, 2013 04:55 AM|murtaza_t|LINK

    APT513

    Where else can it be?

    Can you check if it is mentioned in the web.config. Also check if the dll is added in the handlers.

    Please Mark the post as Answer if it has helped you.
    Regards,
    Murtaza
  • Re: IIS7 503 error service unavailable

    Jan 10, 2013 08:26 AM|APT513|LINK

    Where do I check to see if the dll is added in the handlers?

  • Re: IIS7 503 error service unavailable

    Jan 10, 2013 08:30 AM|murtaza_t|LINK

    APT513

    Where do I check to see if the dll is added in the handlers?

    Double click on Handler Mappings on the server, site, or application Home page.

    Please Mark the post as Answer if it has helped you.
    Regards,
    Murtaza
  • Re: IIS7 503 error service unavailable

    Jan 10, 2013 05:35 PM|APT513|LINK

    There are many handlers. Neither the ones at the server level or the site level *appear* to point to the exchange dll.

    ISAPI-dll - IsapiModule is disabled at the server level.

  • Re: IIS7 503 error service unavailable

    Jan 11, 2013 07:31 AM|murtaza_t|LINK

    Hello,

    It is difficult to assume any thing at this stage and get the solution without having access to the server.

    The error clearly mentions that the ISAPI module in IIS is not loaded hence you will have to find the entry that is calling the DLL and remove it.

    Please Mark the post as Answer if it has helped you.
    Regards,
    Murtaza
  • Re: IIS7 503 error service unavailable

    Jan 11, 2013 07:38 AM|APT513|LINK

    Could the isapi module being disabled be causing the exchange dll error? I dont see how they are related, but if i knew all the answers I would be here!

    I will work on enableing the isapi module.

  • Re: IIS7 503 error service unavailable

    Jan 11, 2013 02:42 PM|APT513|LINK

    Enabling it didnt help matters. Same 503 error.

  • Re: IIS7 503 error service unavailable

    Jan 14, 2013 12:40 AM|murtaza_t|LINK

    Hello,

    You will need someone to look into your system and fix the error for you. If you cannot make that possible then other option is wipeout everything and start from scratch.

    Please Mark the post as Answer if it has helped you.
    Regards,
    Murtaza
  • Re: IIS7 503 error service unavailable

    Jan 15, 2013 05:55 AM|neerajkrshukla|LINK

    double check your applicationHost.config file there must be string name <add key="kerbauth" ... or if not it should be there in web.config, if found comment this line and reset IIS. Other than that try removing integrated windows authentication module this should work.

    Neeraj K Shukla
    ----------------------------------
    Beating a dead horse will not win you the race.
    ----------------------------------
  • Re: IIS7 503 error service unavailable

    Jan 15, 2013 09:17 PM|APT513|LINK

    There isnt a web.config file in there. There is applicationhost.config, admin.config, and redirection.config.

    I can provide a link to the actual applicationHost.config file if that would help.

    Since IIS isnt working and we have no sites or ftp setup, can i just replace the applicationHost.config file with a fresh one?

    i see entries like;

    D:\Program Files\MicrosoftExchange Server\V14\ClientAccess\owa\auth\owaauth.dll" allowed="true" groupId="MSExchangeClientAccess" description="Microsoft Exchange Client Access Server" />
                    <add path="D:\Program Files\MicrosoftExchange Server\V14\ClientAccess\sync\bin\AirFilter.dll" allowed="true" groupId="MSExchangeClientAccess" description="Microsoft Exchange Client Access Server" />
                </isapiCgiRestriction>

    However, Nothing that refrences kerbauth. I did a text search for kerbauth, and kerb with 2 separate txt editors.

  • Re: IIS7 503 error service unavailable

    Jan 16, 2013 02:20 AM|murtaza_t|LINK

    APT513

    However, Nothing that refrences kerbauth. I did a text search for kerbauth, and kerb with 2 separate txt editors.

    Try running a search for kerbauth in registry as well..

    Please ensure that you have a working backup of your registry and do not edit anything in registry unless you are sure what you are upto.

    Please Mark the post as Answer if it has helped you.
    Regards,
    Murtaza
  • Re: IIS7 503 error service unavailable

    Jan 16, 2013 09:38 PM|APT513|LINK

    Did a search of the registry for kerbauth, no results found.

    Very weird that is. Something is calling for it, or it wouldnt be failing. If it isnt in the registry then where?

    Any chance the event log error message is somehow incorrect?

  • Re: IIS7 503 error service unavailable

    Oct 19, 2015 09:02 AM|johninfant|LINK

    Hi APT513,

    Did you figure out how to solve this issue? I did everything you did and still the same. None of the website are running. Please let me know if you have solved this issue.

    Thanks,

    John

  • Re: IIS7 503 error service unavailable

    Nov 23, 2016 06:20 PM|PaulScott|LINK

    I am having the exact same issue, and cannot get any of our sites to come up.  I am thinking about completely uninstalling and then reinstalling IIS (v8.5).  I really hate doing that, so does anybody have a solution to this?