SMF player not playing adaptive streaming when playlistitem added from codebehindRSS

1 reply

Last post Dec 04, 2014 07:56 AM by Michael Nabil

  • SMF player not playing adaptive streaming when playlistitem added from codebehind

    Nov 30, 2012 02:07 PM|SteenN|LINK

    This problem is driving me nuts: I can get ExpressionPlayer to work with playlistitems addes from codebehind and the SMF player also works, when playlistitems is added in XAML. But not when I add playlistitems from codebehind. I use the following code:

    smfPlayer.Playlist.Add(new Microsoft.SilverlightMediaFramework.Core.Media.PlaylistItem   {                

    MediaSource = new Uri(@"http://<server>/<file>.ism/Manifest",UriKind.Absolute),                

    ThumbSource = new Uri(@"http://<server>/<file>_thumb.jpg",UriKind.Absolute),                

    DeliveryMethod = Microsoft.SilverlightMediaFramework.Plugins.Primitives.DeliveryMethods.AdaptiveStreaming   });

    smfPlayer.Play();

    I get no error and when I hit the playlist is says "now playing" - however nothing happens. I use Win8, VS2012, Silverlight 5, SMF 2.7, MicrosoftSmoothStreamingClient 2.0.

    Does anyone know what's going on?

     

  • Re: SMF player not playing adaptive streaming when playlistitem added from codebehind

    Dec 04, 2014 07:56 AM|Michael Nabil|LINK

    Hi Steen,

    I'm facing the same problem and I'm using the same OS VS Silverlight and SMF versions you were using, did you find a solution for your problem.

    Thanks