IIS Site web.config errorRSS

2 replies

Last post Nov 02, 2012 10:19 AM by foundationccc

  • IIS Site web.config error

    Oct 24, 2012 02:12 PM|foundationccc|LINK

    We've tried moving a test site to a new server and are receiving an error when we try to enable Forms authentication. "There was an error while performing this operation. Details: Filename: \\?\C:/inetpub/testsite\web.config Error: Cannot write configuration file." We have verified that the permissions are correct for that site, the App pool is running under "NETWORK SERVICE" and that account has Full permissions on the directory. In fact it appears identical to other sites running fine on that server and everything runs fine on the old testing server. We've tried rebooting, recreating the site, even running the App pool as a domain admin and we still receive this error. If anyone has any ideas/suggestions it would be appreciated. Thanks! PS - forgot to mention this is on Server 2008 R2 (fully updated) with IIS 7.5.
  • Re: IIS Site web.config error

    Oct 25, 2012 11:24 PM|Dalong Zhang - MSFT|LINK

    foundationccc

    In fact it appears identical to other sites running fine on that server and everything runs fine on the old testing server.

     

    Hi,

    Sorry, I did not fully understand you. Do you mean this error just occur on this wesite or all the websites on the new server?

    Your web.config file may be not well formatted, please check it with the old web.config.

    Please mark the replies as answers if they help or unmark if not.
    Feedback to us


  • Re: IIS Site web.config error

    Nov 02, 2012 10:19 AM|foundationccc|LINK

    Sorry for the delayed response. You were dead on with the web.config idea, however it was related to our Devs using Team Foundation Server. TFS was apparently saving the web.config in an odd character encoding (something other than UTF-8) so when we tried to move the files including the web.config over to the test server it blew up.

    Thanks!