FastCGI Error 258 - The FastCGI process exceeded configured activity timeout - (fcgiext.ini not being read) [Answered]RSS

4 replies

Last post Oct 11, 2012 07:35 PM by angrywarrior

  • FastCGI Error 258 - The FastCGI process exceeded configured activity timeout - (fcgiext.ini not b...

    Oct 07, 2012 07:44 PM|angrywarrior|LINK

    So I've been running php with fast cgi for some time and it's been working fine for some time (like 3 4 months after install) but now suddenly I get the error:

     

    FastCGI Error The FastCGI Handler was unable to process the request.

    Error Details: The FastCGI process exceeded configured activity timeout Error Number: 258 (0x80070102).

    Error Description: The wait operation timed out. HTTP Error 500 - Server Error. Internet Information Services (IIS)

     

     

    I have tried to deliberly mess up the fcgiext.ini (the php exe section) to see if any changes was applied (rebooted the server), but nothing happens which in my mind points me to guessing that the ini file is not being read by some strange reason..The fastcgi file is still executed even though the path to it in the ini file is completely wrong..

     

    The weird thing about this issue is that I have not done any changes in the config it self. I had some issue with my WP installation ( /wp-admin/upload.php wont load and timed out). But the rest of the WP install worked fine.

    So a few days ago I changed “display_errors” value from off to on in php.ini file. But that’s it..

     

    Now I am not a pc expert in so I do not really know how to get this fixed..

     

    I'm running:

    • 2003 server entreprise (iis6) SP2 (32 bit)
    • PHP 5.4.5
    • MYSQL MS
    • FAST CGI (fcgisetup_1.5_rtw_x86.msi) WP (latest)

     

    I would be extremly happy for some kind help here because I cannot solve this on my own...

     

    Thanks a bunch! :-)

     

    Regards

     

    Daniel

    iis 6 fastcgi php iis 32 installation FastCGI php IIS 6 fastcgi php5 debugging Configure fcgiext.ini CGI application IIS 6 fastcgi error fcgiext.dll server windows 2003 server FastCGI Error 258

  • Re: FastCGI Error 258 - The FastCGI process exceeded configured activity timeout - (fcgiext.ini n...

    Oct 10, 2012 05:36 AM|Mamba Dai - MSFT|LINK

    Hi,

    angrywarrior

    The FastCGI process exceeded configured activity timeout Error Number: 258 (0x80070102).

    Try increasing the activity timeout, which helps you increase the duration php process:

    http://forums.iis.net/t/1164064.aspx

    http://forums.iis.net/p/1076662/1872096.aspx

    Please mark the replies as answers if they help or unmark if not.
    Feedback to us



  • Re: FastCGI Error 258 - The FastCGI process exceeded configured activity timeout - (fcgiext.ini n...

    Oct 10, 2012 04:19 PM|angrywarrior|LINK

     Thanks for the reply and the links..

     

    I have tried to change that value with no effect, (ActivityTimeout).

    Also as I wrote above in my first post I have also tried to change and fill the the php-cgi.exe path with gibberish in the path to se if anything happened.

     What happens is that the php is still loaded and times out with the errror 258 as mentioned above and IIS give a 500 error aslo.

     However, normal html files loads fine and are shown in the browser.

    Config:

    [Types]
    php=PHP
     

    [PHP]
    ExePath=c:\Webapps\php\php-cgi.exe

    ActivityTimeout=900

    IIS 6 is set to script only  and the .php extension in configuration section points to the fcgiext.dll and the verbs are limited to GET,HEAD,POST. on the sites that are enabled with php.

     

  • Re: FastCGI Error 258 - The FastCGI process exceeded configured activity timeout - (fcgiext.ini n...

    Oct 10, 2012 05:28 PM|angrywarrior|LINK

    Update:

     I tried to mess around with the ini file a little bit more values and added as php.net recommends:

    [Types]
    php=PHP

    [PHP]
    ExePath=c:\Webapps\php\php-cgi.exe
    InstanceMaxRequests=10000
    EnvironmentVars=PHPRC:C:\Webapps\inifiles\
    ActivityTimeout=90
    RequestTimeout=90

     Nothing happens - it just times out and gives the 500 internal server error and the 258 error.

     

    I aslo found this in the event viewer on the server in applications section:



    but I've been googleing and the php_zip.dll is not included/missing the php 5.4.X version?

    so what to do here? - If I understand it right WP requires that php extension to be enabled?


     

    I have even tried to remove the  ExePath=c:\Webapps\php\php-cgi.exe path section. and the result is:


    FastCGI Error

    The FastCGI Handler was unable to process the request.

    Error Details:

    • Section [PHP] not found in config file.
    • Error Number: 1413 (0x80070585).
    • Error Description: Invalid index.

    HTTP Error 500 - Server Error.
    Internet Information Services (IIS)

     

  • Re: FastCGI Error 258 - The FastCGI process exceeded configured activity timeout - (fcgiext.ini n...

    Oct 11, 2012 07:35 PM|angrywarrior|LINK

     Well I called the quits and gave up and reinstalled the whole darn thing and now its working...

    Thanks everyone for trying to help me!

    Thanks

    Daniel