Getting 404 error when trying to access the default Web site (IIS 7) [Answered]RSS

6 replies

Last post Aug 28, 2012 04:28 PM by cshore11

  • Getting 404 error when trying to access the default Web site (IIS 7)

    Aug 23, 2012 10:40 AM|cshore11|LINK

    I've created a Web site in IIS, and am getting a 404 error ("The requested URL /ElectionPollingPlace/Default.htm was not found on this server.") when I try to load it. The site loads successfully on another analyst's machine, so that's not the problem. I've done any number of things to get this to work right:

    1) Verifying my applicationHost config file

    2) Changing my http port to 81.

    3) Activating the cgi software.

    I'm running IIS 7 on Windows 7, and using application pool ASP.Net 4.0.  At this point I have no idea where to go next.

    IIS7 ASP.NET CGI host port 404.0 httperror

  • Re: Getting 404 error when trying to access the default Web site (IIS 7)

    Aug 23, 2012 11:53 AM|fab777|LINK

     Hi,

    first you have to check if the application pool identity has the read&execute NTFS permissions rights on the file.

    This message is provided "AS IS" with no warranties... But you can still mark it as answer if it's helped you.
    Fabrice ZERROUKI
    Wanna chill out? Here: JAHSound.net
  • Re: Getting 404 error when trying to access the default Web site (IIS 7)

    Aug 23, 2012 03:30 PM|cshore11|LINK

    Thanks for the rapid response.  I found an article by Ken Schaefer that addresses what I think you’re talking about.  I didn’t really understand the gobblygook that he refers to, but did run the icacls executable that he mentioned, on the Default App pool.  The output I got was:

    NT AUTHORITY\SYSTEM (OI)(CI)(F)

    BUILTIN\Administratos(OI)(CI)(F)

    IIS APPPOOL\Default(0I)(CI)(R)

     

    Can someone explain in something similar to English if these permissions are set correctly.  Furthermore, how does all this apply to the .Net 4.0 app pool?

    Thanks again.

     

  • Re: Getting 404 error when trying to access the default Web site (IIS 7)

    Aug 24, 2012 03:49 AM|fab777|LINK

    NT AUTHORITY\SYSTEM (OI)(CI)(F)

    BUILTIN\Administratos(OI)(CI)(F)

    IIS APPPOOL\Default(0I)(CI)(R)

    This means you gave the permission "Full Control" to the system ans the administrators group. That's required. You also gave the "Read" permission to the account that runs IIS. To serve the page to the internet user, you web server (so the 'IIS APPPOOL\Default' account) needs to be able to access the file, at least read it if it's a static page. You will need the "Read & Execute" permissions for dynamic pages.

    Note that this account is right only if you didn't change the account for ApplicationPoolIdentity

    This message is provided "AS IS" with no warranties... But you can still mark it as answer if it's helped you.
    Fabrice ZERROUKI
    Wanna chill out? Here: JAHSound.net
  • Re: Getting 404 error when trying to access the default Web site (IIS 7)

    Aug 27, 2012 09:08 AM|cshore11|LINK

    Sorry, I'm still not getting this.  How would I change the IIS APPPOOL\Default account from 'R' to 'F'?

    I changed my Default App Pool Identity setting from ApplicationPoolIdentity to NetworkService.  That didn't work either.  Anyway, according to the guidance, I shouldn't have to make any changes when running IIS7.5 (against a Windows 2008 R2 server).

     

     

    IIS APPPOOL

  • Re: Getting 404 error when trying to access the default Web site (IIS 7)

    Aug 27, 2012 02:21 PM|monoliths|LINK

    Can you tell which 404.xx error you are getting? This might help if it is a permissions configuration issue: http://www.bluevalleytech.com/techtalk/blog/assigning-ntfs-folder-permission-to-iis7-application-pools/
  • Re: Getting 404 error when trying to access the default Web site (IIS 7)

    Aug 28, 2012 04:28 PM|cshore11|LINK

     It's 404.0.

    I looked over your Web site and tried to  add another application pool.  I'm 99% sure we're running against R2;  however, when I clicked 'Add Application Pool...', I got an 'Add Application Pool' dialog box rather than a 'Select Users or Groups' box.  When I tried to add 'IIS APPPOOL/ElectionPollingPlace' to my box, I got a message indicating that I couldn't include special characters in the name.