Error 404.2 ISAPI and CGI list settings restrictions list settings on Web ServerRSS

2 replies

Last post Aug 02, 2012 03:36 AM by Lloydz

  • Error 404.2 ISAPI and CGI list settings restrictions list settings on Web Server

    Jul 27, 2012 03:15 PM|carywinton|LINK

    After installing .Net Framework 4.0 I get an error 404.2 ISAPI and CGI list settings restrictions list settings on Web Server. This errror is displayed when trying to access Joomla, PHPBB and WordPress.

    Any assistance with this would be appreciated, everything was working fine until this update was installed by Microsoft Update.

    WordPress Joomla 2.5 PHPBB3 error 404.2

  • Re: Error 404.2 ISAPI and CGI list settings restrictions list settings on Web Server

    Jul 27, 2012 04:43 PM|carywinton|LINK

    Solved! When .NET Framework 4.0 is installed it is not "Enabled" by default in IIS 7, you have to "allow" it in IIS 7 manager, click on your server name, not the website that is not displaying the page, in my case the ISAPI and CGI Restriction icon only appears there. Open up ISAP and CGI restrictions and enable both entries for .NET Framework 4.0.
  • Re: Error 404.2 ISAPI and CGI list settings restrictions list settings on Web Server

    Aug 02, 2012 03:36 AM|Lloydz|LINK

    Yes, isapi filter restrictions settings can be only configured at server level. Thanks for sharing the solution. Glad to see you have worked it out. :)