We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Web Farm Framework 2.2 Installation ProblemsRSS

9 replies

Last post May 02, 2016 10:08 AM by cybernaresh

  • Web Farm Framework 2.2 Installation Problems

    Jul 12, 2012 08:02 PM|N834|LINK

    I have an IIS 7 environment running on Server 2008 R2. I have tried to install Web Farm Framework 2.2 with no luck. I have tried using the Web Platform Installer 4.0, I have launched the Web Farm Framework 2.2 app for the Web Platform Installer, and have tried the WebFarm2_x64.msi directly. Every time I initiate an install, it fails saying that: " This product did not install successfullly: Web Platform Installer is a pre-requisite for installing Web Farm Framework. Please install the Web Platform Installer from.." That's the message I get from the Web Platform Installer. I have the error log as well if it helps. Thanks in advance, Nate

    webfarmagentservice webfarm install products

  • Re: Web Farm Framework 2.2 Installation Problems

    Jul 12, 2012 09:13 PM|harshmittal|LINK

    WFF depends on Web Platform Installer (WPI)v3. Please use WPI3 for getting around this issue.
  • Re: Web Farm Framework 2.2 Installation Problems

    Jul 13, 2012 11:13 AM|N834|LINK

    Perfect. That worked like a champ. Thanks!
  • Re: Web Farm Framework 2.2 Installation Problems

    Aug 22, 2012 09:04 AM|afterburner33|LINK

    I am having a similar issue. I had WPI 4.0 installed, and was getting the same problem as the original poster. After reading this post, I uninstalled WPI 4.0, installed WPI 3.0, and re-ran the installer for WFF 2.2. However it seems that WFF 2.2 insists on upgrading the WPI version to 4.0 before it will install, and once it has done this, it then fails with the same error as it did originally! This happens whether I run the WFF installer via WPI or via the stand alone installer. This is genius - it won't work with WPI 4.0, but won't install without it. Does anyone know a way around this? Thanks
  • Re: Web Farm Framework 2.2 Installation Problems

    Aug 22, 2012 10:15 AM|N834|LINK

    Yeah, when it asks to install WPI 4.x, just "X" out of it. Don't "Disagree" to the terms window, just close it. Nate
  • Re: Web Farm Framework 2.2 Installation Problems

    Sep 11, 2012 10:00 AM|Laurent Lesle|LINK

    Any ideas if a new version of WFF will be working with Web Platform Installer 4.0?
  • Re: Web Farm Framework 2.2 Installation Problems

    Sep 11, 2012 01:12 PM|Underground|LINK

    There's also apparently a WFF 2.2 dependency on another older version component, Web deploy v2.

     I believe that's the one that will actually "help" you out by installing WFF 1.1.

  • Re: Web Farm Framework 2.2 Installation Problems

    Jun 23, 2013 02:29 AM|Kevin Yang|LINK

    Hi, does anyone solved this stupid installer problem??

    i can't see why microsoft produce this most stupidest installer ever.

    i have a server which has extremely slow network connection to download.microsoft.com, 

    and WINDOWS DNS resolver protect me from change that DNS using hosts file.

    so i can't simplely change to a relative fast ip.

    and seems that many IIS plugin require the SO-CALLED web installer platform, which is rubbish.

    installer webfarmagentservice webfarm install products

    -----------------------------
    Have a Good Day !!
    -----------------------------
    ---- Kevin Yang ----

    http://www.imkevinyang.com/
  • Re: Web Farm Framework 2.2 Installation Problems

    Sep 12, 2013 10:32 AM|znerses|LINK

    I ran into the same problem. Pretty annoying.
    I was able to fix it by manually installing Web Platform Installer 3.0 and then manually installing Web Farm Framework 2.2.

    Don't use the old wplouncher for WPI, because it will automatically download the latest version. Instead, use this file:

    http://www.microsoft.com/en-us/download/details.aspx?id=6164

    Once you are done with this, install WFF 2.2 by directly downloading from here:
    http://www.microsoft.com/en-us/download/confirmation.aspx?id=27723

    webfarmagentservice webfarm install products

  • Re: Web Farm Framework 2.2 Installation Problems

    May 02, 2016 10:08 AM|cybernaresh|LINK

    Thanks 'znerses'. Your solution worked!

    Though I have wpi 5.0 installed, the issue continued, but when installed wpi 3.0, then wff 2.2 got installed without any issues (this is weird scenario though).