HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in the binding. IIS 7.5, win 7 ult. [Answered]RSS

8 replies

Last post Mar 24, 2013 05:58 AM by neeraj.bajaj

  • HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in the...

    Mar 02, 2012 02:46 PM|ImaEtte|LINK

    I have a static content site that loads normally when "All unassigned" or 2 other virtual adapters on my pc is used in the binding. Whenever I select the main physical adapter's Ip, I get the "HTTP Error 404. The requested resource is not found". This adapter is the one used in my internal LAN and for internet access. I've added an entry in the hosts file: 172.16.4.3 localhost (host header) for this but still doesn't work. I need help in resolving this. Thanks.

    404 error from IIS 7.0

  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 03, 2012 04:32 AM|lextm|LINK

    When you receive 404 error page, what is the URL used in the browser? And why can't you use "All Unassigned"?
    Lex Li
    Affordable IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 05, 2012 04:26 AM|Leo Tang - MSFT|LINK

    Hi,

    Have you resolved this issue? If your problem persists, could you please post the relevant IIS log entries and the output of following command here?

    C:\Windows\System32\inetsrv>appcmd list sites

    IIS log files located in C:\inetpub\logs\LogFiles by default.

    Please mark the replies as answers if they help or unmark if not.
    Feedback to us


  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 06, 2012 12:19 AM|kctt|LINK

     On your server test ping localhost and ping 172.16.4.3

    by default localhost is 127.0.0.1

  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 06, 2012 12:14 PM|ImaEtte|LINK

    Leaving the host header blank solved the issue. Thanks for all the tips.
  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 03, 2013 04:31 PM|neeraj.bajaj|LINK

    guys, can you please help me out. i need to keep host header configurations and i am getting 404 not found.

    appreciate pointers

  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 18, 2013 10:10 AM|adit|LINK

    I am also getting same issue since this moth. Is this any patching issue released by MicroSoft? Before it was working fine. Any one have any idea?

  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 18, 2013 10:16 AM|adit|LINK

    Even I am getting the same issue in iis 7.5. Any idea anyone 

  • Re: HTTP Error 404. The requested resource is not found - occurs when a particular ip is used in...

    Mar 24, 2013 05:58 AM|neeraj.bajaj|LINK

    any luck guys.. what is the limitation with host header? any IIS module gets overridden when we implement host header..

    4 Posts

    <div class="comment-right-col">

    Re: host header configuration issue - iis 7.0

    a few seconds ago|LINK

    <div>

    few  observations-

    1. after implementing host header configuration in IIS, checked with Fiddler and noticed browser expects /favicon.ico file and it does not get it. it seems IIS is not able to serve this particular object and it becomes mandatory requirement.

       Checked Staticmodule is added in IIS and .ico mimetype is also added. also placed the favicon.ico file in root directory but no help..

    2. If host header configuration is removed then site works fine, however in fiddler still expects /favicon.ico but only after all other objects are successfully loaded and /favicon.ico is even not present in root directory.

    appreciate any pointers.. is it something to do with some module has higher precedence over other?

    </div> </div>