IIS Control Panel missing ARR items [Answered]RSS

6 replies

Last post Feb 16, 2012 06:35 PM by richma

  • IIS Control Panel missing ARR items

    Dec 09, 2011 11:56 AM|esmith3|LINK

    Hi.  We recently noticed that on win2008R2 servers which only had the O/S and Sqlserver installed, that after installing ARR 2.5 via WebPI we are not able to see the ARR items in the IIS control panel (as started via inetmgr.exe).  Specifically we do not see the 'server farms' in the left panel, nor the 'URL Rewrite' nor 'Application Request Routing Cache' icons in the middle panel.  I do not see errors in the event viewer.  I do not see [relevant] errors in the ARR log files (I dont see a way to attach to this post but I have the logs if wanted).

     HOWEVER we didn't notice this problem because ARR is working!  We have Rewrite rules and Server farms working correctly.  Further, if I dump out the IIS metadata via APPCMD LIST CONFIG, I see all our (scripted) rules and farm entries are correctly defined.

    Further, if we install ARR on a win2008R2 server which had been up and running for months with numerous other software installs on it, then ARR shows up in the IIS control panel.

    1) Is there any 'quick fix' to make these show up in IIS? 

    2) We can work with your ARR Support staff to faciliate access to a machine showing this.

    We are working to confirm if the same issue occurs for win2008(notR2).  The systems where this has occurred are all virtual servers -- which I would assume is indetectable; we're looking to see if we have a non virtual box to try this on.

    Thx.

    ARR

  • Re: IIS Control Panel missing ARR items

    Dec 13, 2011 09:40 PM|Lloydz|LINK

    Hi,

    Have you restarted IIS Manager after installing ARR? ARR features are available at server level only. It's really werid that IIS Manager doesn't show the feature with a successful installation and didn't report anything in event viewer. If the issue persists, I would suggest you do a reinstall of the module to see if this provide a quick fix.

    Thanks.

  • Re: IIS Control Panel missing ARR items

    Dec 14, 2011 10:37 AM|richma|LINK

    There is a similar issue posted here where the issue only existed when viewed in Server Manager

    http://forums.iis.net/p/1159733/2004212.aspx#2004212

    Can you confirm that its broken in both ServerManager and in Inetmgr.exe

    Also could you tell me what are the versions of ARR and WEb Farm Framework listed in the Add Remve programs ?

    Thanks

     Richard

  • Re: IIS Control Panel missing ARR items

    Dec 14, 2011 10:59 AM|esmith3|LINK

    Update:

    - (per my SA) this issue occurs under win2008R2 only (not win2008notR2) when ARR 2.5 is installed using WPI PRIOR to setting up the IIS role (Server Manager / Roles summary / Webserver (IIS) / Add Roles / Webserver IIS).

    - when the issue occurs, the \windows\system32\inetsrv\config\administration.config file section <moduleProviders> is missing the ARR-related providers.  {I did not check if applicationHost.config correct.}  However, as noted above, the farms and rules are in place and working.

    - when the issue occurs, both the server manager and inetmgr.exe are missing the items.

    - simply editing the administration.config (and restarting IIS Admin + www) did not make the items reappear

    - using Programs and then 'repair' option for each ARR component (and WPI) did not make the items reappear

    - the solution we found (tested only once) was to deinstall all 4 ARR programs (cache, url, arr, farms) and WPI, then reinstall WPI and then ARR, and then recreate (our) farms and rules.

    - we found the issue did occur regardless of whether SP1 was first applied to the win2008R2 O/S.

     

  • Re: IIS Control Panel missing ARR items

    Dec 20, 2011 06:07 AM|Adrian B.|LINK

    esmith3

    Update:

    - (per my SA) this issue occurs under win2008R2 only (not win2008notR2) when ARR 2.5 is installed using WPI PRIOR to setting up the IIS role (Server Manager / Roles summary / Webserver (IIS) / Add Roles / Webserver IIS).

    - when the issue occurs, the \windows\system32\inetsrv\config\administration.config file section <moduleProviders> is missing the ARR-related providers.  {I did not check if applicationHost.config correct.}  However, as noted above, the farms and rules are in place and working.

    - when the issue occurs, both the server manager and inetmgr.exe are missing the items.

    - simply editing the administration.config (and restarting IIS Admin + www) did not make the items reappear

    - using Programs and then 'repair' option for each ARR component (and WPI) did not make the items reappear

    - the solution we found (tested only once) was to deinstall all 4 ARR programs (cache, url, arr, farms) and WPI, then reinstall WPI and then ARR, and then recreate (our) farms and rules.

    - we found the issue did occur regardless of whether SP1 was first applied to the win2008R2 O/S.

     

    Thanks. That worked out.
  • Re: IIS Control Panel missing ARR items

    Jan 05, 2012 04:07 PM|richma|LINK

    I wanted to confirm that we can reproduce and found the reason for this behavior.

    When installing ARR using WebPi on a system with no IIS , ARR will add the WebServerRole and the Static Content Module as  a baseline requirement for running ARR.

    However it does not add the IIS Management Console, therefore during this installation there is nowhere to registerd the features for the UI.

    Then as you found even if you add this later it does not resolve then  issue.

    From my tests you can add the IIS Management Console during the WebPi setup and this will resolve the problem and not require the re-install.

    We are also working on getting this updated so  we add IIS Management Console to the dependency list when installing ARR.

    Thank you for your time in reporting this.

  • Re: IIS Control Panel missing ARR items

    Feb 16, 2012 06:35 PM|richma|LINK

    Thanks Everyone for the feedback  on this.

    The WebPI Feeds have been updated to include the IIS Management Console Dependency to resolve the issue where neither Inetmgr.exe or Servermanager show the ARR icons.