FastCGI error [Answered]RSS

3 replies

Last post Nov 21, 2011 09:32 AM by HCamper

  • FastCGI error

    Nov 21, 2011 08:08 AM|razamit|LINK

    I am trying to install wordpress on iis but I cant seem to make it work.

     I keep recieving the following error:

     Error Summary

    HTTP Error 500.0 - Internal Server Error

    An unknown FastCGI error occured

    <div class="content-container">
    Detailed Error Information<div id="details-left">
    Module FastCgiModule
    Notification ExecuteRequestHandler
    Handler PHP52_via_FastCGI
    Error Code 0x8007010b
    </div><div id="details-right">
    Requested URL http://localhost:80/blog/index.php
    Physical Path C:\inetpub\wwwroot\Blog\index.php
    Logon Method Anonymous
    Logon User

    Anonymous

    </div><div> </div><div>I cant seem to make it work...</div><div> </div><div>Please help</div>
    </div>

    fastCGI error fastcgi module IIS 7.0 fascgi wordpress

  • Re: FastCGI error

    Nov 21, 2011 08:20 AM|HCamper|LINK

    Hi,

    Check the FastCGI path settings:

    2. In the Actions pane, click Add Module Mapping.... In the Add Module Mapping dialog box, specify the configuration settings as follows:

  • Request path: *.php
  • Module: FastCgiModule
  • Executable: "C:\[Path to your PHP installation]\php-cgi.exe"
  • Name: PHP via FastCGI

  •  

    Also make sure IUSR and IIS_IUSRS have read,execute,list permissions

    for:

    Physical Path C:\inetpub\wwwroot\Blog\index.php

    What are the Application Pool settings http://learn.iis.net/page.aspx/624/application-pool-identities/ for the Blog

    " Net 2.0 and Classic Mode"  ?

    IIS Net Reference http://learn.iis.net/page.aspx/246/using-fastcgi-to-host-php-applications-on-iis/

    Martin

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: FastCGI error

    Nov 21, 2011 08:56 AM|razamit|LINK

    The premissions was the problem..

    Thanks!

    No ihave a different problem...

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    • Are you sure you have the correct username and password?
    • Are you sure that you have typed the correct hostname?
    • Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    Try Again

     I thought the wordpress installation creates the database. Am I wrong?

  • Re: FastCGI error

    Nov 21, 2011 09:32 AM|HCamper|LINK

    Hi,

    Cool just permissons :).

    Yes Wordpress does create the Database for first time setup. Your correct :D.

    If you get stuck http://forums.iis.net/t/1177760.aspx this is one of the ways out.

    The other is install http://www.heidisql.com/ Heidesql and logon with the "Root" account.

    Open the "wp-config.php" for the current settings.  Make sure MySQL Server is running.

    Using "Root"  Drop the current WP Database. Using "Root" Create new WP Database ( empty). 

    Using "Root" Modify User for  the WP_USER password and permissions.

     Grant Permissions for WP_USER  for localhost Access.

    Grant WP_USER permissions for WP Database.

    Then backup wp-config.php and either use the existing / modified  settings or run the first-time-setup.

    Martin

     

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011