We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

IIS issues with .NET applicationRSS

18 replies

Last post Dec 06, 2011 06:10 AM by qbernard

  • IIS issues with .NET application

    Nov 15, 2011 07:12 PM|BBhaiD|LINK

    Hi,

    I have few applications which displays the following error message after few hours every day.

    error reading configuration information from the registry

    to fix this error, i always have to restart the application pool. this is getting annoying and wasting a lots of time of users. Please help. The applications that keep on falling have been developed with .NET Framework 2.0. The IIS is installed on win server 2003.

  • Re: IIS issues with .NET application

    Nov 15, 2011 10:41 PM|qbernard|LINK

    Can you post the exact error msgs? is it from .net or your app ?
    have not seen this msgs from IIS before.
    Cheers,
    Bernard Cheah
  • Re: IIS issues with .NET application

    Nov 15, 2011 11:03 PM|BBhaiD|LINK

    The above posted error message is the exact one "error reading configuration information from the registry". we have about 12 applications on that server and 6 applications keeps on doing that once or twice a day. Restarting the application pool for these applications fixes the error message. this message should not have anything to do with the application but something else and i am not sure. it can't be permission issue since restarting the application pool fixes the error.
  • Re: IIS issues with .NET application

    Nov 17, 2011 12:00 AM|qbernard|LINK

    That's the full error msgs? one liner with no other info? is this error msgs from your app itself?

    what about event log? IIS logs ?

    Cheers,
    Bernard Cheah
  • Re: IIS issues with .NET application

    Nov 21, 2011 08:21 PM|BBhaiD|LINK

    Here you go, this is the exact one that displays:

     


    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Error reading configuration information from the registry.

    Source Error:

    Line 69:       <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>
    Line 70:     </httpHandlers>
    Line 71:     <identity impersonate="true" userName="registry:HKLM\SOFTWARE\PDS\identity\ASPNET_SETREG,userName" password="registry:HKLM\SOFTWARE\PDS\identity\ASPNET_SETREG,password"/>
    Line 72:     <compilation debug="true" strict="false" explicit="true">
    Line 73:       <assemblies>



    Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053 

     

  • Rovastar Rovastar

    5495 Posts

    MVP

    Moderator

    Re: IIS issues with .NET application

    Nov 21, 2011 09:05 PM|Rovastar|LINK

    http://www.velocityreviews.com/forums/t704027-windows-server-2008-error-reading-configuration-information-fromthe-registry.html

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: IIS issues with .NET application

    Nov 22, 2011 04:21 AM|qbernard|LINK

    Ohhh .net error msgs... so have you set the relevant permission?

    Cheers,
    Bernard Cheah
  • Re: IIS issues with .NET application

    Nov 29, 2011 10:34 PM|BBhaiD|LINK

     I have set the permissions. That's why just restarting the application pool fixes the issue but only for few hours or may be a day and then it happens again and have to restart the application pool.

  • Re: IIS issues with .NET application

    Nov 30, 2011 05:36 AM|qbernard|LINK

    You got the error msgs, even after you applied the correct permission? that's weird.

    Same error msgs?

    Cheers,
    Bernard Cheah
  • Rovastar Rovastar

    5495 Posts

    MVP

    Moderator

    Re: IIS issues with .NET application

    Nov 30, 2011 05:41 AM|Rovastar|LINK

    Did you read that link I gave and add

    app\identity\ASPNET_SETREG 

    to the registry?

    I consider this an app issue.

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: IIS issues with .NET application

    Nov 30, 2011 08:17 AM|BBhaiD|LINK

    Yes i did read the link but that has already been done and that's why the application works but then the application pool has to be restarted

     

  • Re: IIS issues with .NET application

    Dec 01, 2011 01:24 AM|qbernard|LINK

    Restart? to make the setting effective? well, ya. as the token still cache, if you want it to be effiective immediately, then need to restart the worker process.
    Cheers,
    Bernard Cheah
  • Re: IIS issues with .NET application

    Dec 01, 2011 02:02 AM|BBhaiD|LINK

     what i meant was that the application pool has to be restarted like few times a day. It throws the error reading configuration information from the registry and then if we restart the application pool, that fixes the issue. but this issue happens quite a number of times each day.

  • Re: IIS issues with .NET application

    Dec 01, 2011 02:18 AM|HCamper|LINK

    Hi,

    I have a question:

    What is installed that relates to registery the registery SOFTWARE \ PDS ?

    Edit: Update PDS Net 2.0 in house application.

    Martin

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: IIS issues with .NET application

    Dec 01, 2011 08:21 PM|BBhaiD|LINK

     PDS (Phone directory system) is a in-house application that we developed with .NET framework 2.0. You won't find anything on google on this application but this is not the only application that falls over, there are quite a few that falls along with it.

  • Re: IIS issues with .NET application

    Dec 01, 2011 08:47 PM|HCamper|LINK

    Hi,

    Thanks for the information so PDS is a in-house Net 2.0 Application.

    The  "ASP.NET IIS Registration Tool"   http://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx 

    Community Content and the -ga option for Accounts ?

    Just a suggestion,

    Martin

     

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: IIS issues with .NET application

    Dec 05, 2011 01:13 AM|qbernard|LINK

    Is it the same error ? If you didn't solve it, it will just keep happening again. You can try debugdiag and try to find more info about the crash.

    If it is the same error, then can you use procmon to trace who is accessing the registry. as this seems intermediate to me. any pattern you capture? say certain hours, certain transaction/vol ?

    BBhaiD

     what i meant was that the application pool has to be restarted like few times a day. It throws the error reading configuration information from the registry and then if we restart the application pool, that fixes the issue. but this issue happens quite a number of times each day.

    Cheers,
    Bernard Cheah
  • Re: IIS issues with .NET application

    Dec 05, 2011 09:56 PM|BBhaiD|LINK

     No pattern at all. It happens randomly. Sometimes it doesn't happen for days and sometimes it happens every few hours. Can it happen if the application server is too busy?

  • Re: IIS issues with .NET application

    Dec 06, 2011 06:10 AM|qbernard|LINK

    Well, hard to tell without any log.
    But the thing that puzzle me is - even after you applied the permission, you still getting it, that doesn't make sense :)
    You sure is the same reg key? same account ? etc ?

    Cheers,
    Bernard Cheah