We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Error in Starting WebMatrix correctly [Answered]RSS

6 replies

Last post Sep 29, 2011 04:12 AM by simtan

  • Error in Starting WebMatrix correctly

    Sep 02, 2011 12:01 AM|xer_eibru|LINK

    Good day to all. Any one can help me with my problem in starting my Microsoft WebMatrix. When I open it, a message appear like below: An error prevented WebMatrix from starting correctly. Error Message: Object reference not set to an instance of an object. Error Log File: C:\Users\XYLVES~1\AppData\Local\Temp\WebMatrix.exe.log Click 'Yes' to visit the online forums for more information. Please help me everyone with this problem. Thank you very much.

    WebMatrix database webmatrix publish .net4.0 .net3.5 webmatrix crash

  • Re: Error in Starting WebMatrix correctly

    Sep 02, 2011 01:06 AM|xer_eibru|LINK

    from the webmatrix.exe.log 9/2/2011 11:54:30 AM -------- ResourceName: Microsoft.WebMatrix.Server.WebManagementServiceException: Object reference not set to an instance of an object. ---> System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.WebMatrix.Client.SharedMemoryChannel.CreateManagementUnit(ManagementFrameworkVersion frameworkVersion) at Microsoft.WebMatrix.Client.SharedMemoryChannel.InvokeInternal(String serviceName, String methodName, Object[] parameters) --- End of inner exception stack trace --- at Microsoft.WebMatrix.Client.SharedMemoryChannel.MTAHelper.Execute(String serviceName, String methodName, Object[] parameters) at Microsoft.WebMatrix.Client.SharedMemoryChannel.Invoke(String serviceName, String methodName, Object[] parameters) at Microsoft.WebMatrix.Host.ConnectionManager.GetWebManagementInfo(Connection newConnection, Boolean retrieveModules, Boolean retrieveUrl) at Microsoft.WebMatrix.Host.ConnectionManager.ActivateConnection(ConnectionInfo connectionInfo) at Microsoft.WebMatrix.Host.ConnectionManager.Microsoft.WebMatrix.Client.IConnectionManager.ActivateConnection(ConnectionInfo connectionInfo) at Microsoft.WebMatrix.Host.Shell.ShellMainWPF.ActivateWebMatrixLocalConnection() at Microsoft.WebMatrix.Host.Shell.ShellMainWPF..ctor(IServiceProvider serviceProvider, SplashScreen splash) at Microsoft.WebMatrix.Host.Shell.ShellApplication.Execute(Boolean localDevelopmentMode, Boolean resetPreferences, Boolean resetPreferencesNoLaunch, Boolean warmupMode)
  • Re: Error in Starting WebMatrix correctly

    Sep 02, 2011 02:48 AM|HCamper|LINK

    Hi,

    There is a Web Matrix Thread http://forums.iis.net/t/1180755.aspx with

    suggestions for the type of errors your getting.

    You may need to change your desktop settings for Theme Font Text Size and the Dots Per Inch ( DPI) 

    The picture and settings guide at the Server Forums http://www.sevenforums.com/tutorials/443-dpi-display-size-settings-change.html 

    should help.

    Martin

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: Error in Starting WebMatrix correctly

    Sep 02, 2011 12:24 PM|HCamper|LINK

    Hi,

    If the current suggestion are not working:

    You can check the Web Matrix 1.0 Release notes http://www.microsoft.com/web/post/webmatrix-10-release-notes that

    contain information about problems and suggestions.

    Martin

     

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: Error in Starting WebMatrix correctly

    Sep 03, 2011 07:34 AM|xer_eibru|LINK

    Hi @HCamper, unfortunately, i still don't have spotted solution for this problem....thanks anyway for sending these recommendations sir. I think this issue is a programming issue....I'm still hoping for any kind of solutions for this problems....thanks :)
  • Re: Error in Starting WebMatrix correctly

    Sep 03, 2011 08:26 AM|HCamper|LINK

    Hi,

    Yes, There is a programming issue of some kind and it is related to the start-up of Web Matrix. 

    The failure to create object is not something you have done or can change.

    You should look at this http://forums.iis.net/p/1177817/1980880.aspx#1980880 Thread

    And changes for Registery Keys:

    <div class=ForumPostContentText>

    Under HKLM\Software\Microsoft\WebMatrix (HKLM\Software\Wow6432Node\Microsoft\WebMatrix on 64 bit OS) make a string key called "InstallPath"

    Then for the value set it to "C:\Program Files\Microsoft WebMatrix\" ("C:\Program Files (x86)\Microsoft WebMatrix\ on a 64 bit OS.

     It's worth a shot but I imagine something else will break down the line since I imagine most (all) of the other registry keys are missing.

    </div>

    What kind of Windows Cleaners  Optimization tools Anti-Virus Anti-Maleware tools are installed or have been run

              on your Windows System?

    Reference: Information for using Windows Registry Microsoft Support http://support.microsoft.com/kb/256986 .

    If you need more information about Regedit or registery ask or post questions. 

     Martin

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: Error in Starting WebMatrix correctly

    Sep 29, 2011 04:12 AM|simtan|LINK

    If you are running WebMatrix 1, you might want to also try WebMatrix 2 (Beta) to see if the problem is resolved there:

    http://webmatrix.com/next

    Simon Tan
    Program Manager
    Web Platform and Tools