We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Can't access my new website and webservice in my IIS7 [Answered]RSS

2 replies

Last post Mar 30, 2011 07:25 AM by KristoferG

  • Can't access my new website and webservice in my IIS7

    Mar 28, 2011 03:33 PM|Taichung|LINK

     I'm using asp.net 3.5,IIS7
    My IIS7 default web site is used for our CMS Sitecore and its websites, port 80.  I seem to get an error when I add my webservice in this website, port 88.  I then created a new website project and a separate web service project.  I added the website to IIS7 as 2nd website and in there I added an Applicaton fro the webservice.  I also went to Windows Firewall and Enable the "World wide web(http).  
    Now when I type in url, http://localhost:88/FindPhysicians/default.aspx, for my 2nd web site I would get
    The resource cannot be found.
    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /FindPhysicians/default.aspx

    I open up my 2nd web site in VS 2008 to add this web service by entering http://localhost:88/services/GetPhysicianInfo.asmx
    and I get the same type of error message that
    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed

    How can I fix this?  Thank you.

  • Re: Can't access my new website and webservice in my IIS7

    Mar 30, 2011 04:18 AM|Linda-in-spring|LINK

    Hi,
     
    Please try the following steps to see if this works:
    Open IIS Manager
    à Click your site à Switch to content view à Right Click the page and select browse
     
    If the problem still exists, I suggest you enable failed request tracing to further troubleshooting the issue:
     
    Troubleshooting Failed Request Using Tracing in IIS7
    http://learn.iis.net/page.aspx/266/troubleshooting-failed-requests-using-tracing-in-iis-7/
     
    Thanks.

  • Re: Can't access my new website and webservice in my IIS7

    Mar 30, 2011 07:25 AM|KristoferG|LINK

    If you try to access that link locally on the server, you will get a more informative error message. You can also change this behavior so you see it on a remote client with the following steps:

    • In IIS Manager, click the website or virtual directory (depending on which level you want to configure this)
    • In the middle pane, double click on "Error Pages"
    • In the right pane, click "Edit Feature Settings"
    • Select "Detailed Errors" and click Ok

    Now try to make this request using Internet Explorer.

    If you still do not have anything that helps, please use WFetch and request the same URL. This will reveal exactly what response you got (maybe you are seeing a 404, but in reality it cannot connect to the server).

    Kristofer Gafvert

    http://www.it-notebook.org