We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Error 500.19 Error Code: 0x8007000d Config source -1: 0: [Answered]RSS

7 replies

Last post Jun 28, 2013 05:06 AM by Phil.Hartmann

  • Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    Mar 28, 2011 02:54 PM|peters196|LINK

     I am having problems installing Drupal 7.0. However I think it is an IIS problem.

    When I execute the install program: http:\\myweb\Drupal-7.0\install.php I get an error 500.19 Internal Server error.

    'The requested page cannot be accessed because the related configuration data for the page is invalid'

    The detail of the error are:

    Detailed Error information:
    Module: IIS Web Core
    Notification: Begin Request
    Handler: Not yet determined
    Error Code: 0x8007000d
    Requested URL: http://localhost/myweb/drupal-7.0/install.php
    Physical path: c:\inetpub\wwwroot\myweb\drupal-7.0\install.php
    Login Method: Not yet determined
    Login User: Not yet determined
    Config Error
    Config File: \\?
    \C:\inetpub\wwwroot\myweb\drupal-7.0\web.config

    Config Source:
    -1:
    0:

    Drupal has its own web.config file (listed below). If I edit it to introduce a deliberate error (mis-matching tags)   the two lines in error and an explanation of the error is shown under the 'Config source' heading.

    If I comment out everything except the configuration and system.webserver tags I get the same error (Config source -1: 0:).

    Editing out more, or deleting this web.config file I get the error 404 Not found.

    I am running IIs7 on Windows 7 Ultimate and granted full permission to the inetpub folder according to the post by Thomad on http://forums.iis.net/t/1147354.aspx.

    The error message suggests that the error is on lines -1 and 0. I have run the drupal web.config file through an XML verifier/syntax checker and it checks out ok. There is nothing before the <?xml tag, and nothing after the last closing tag.

    Can you help please!

    Web.config: (in the c:\inetpub\wwwroot\myweb\Drupal-7.0\ folder)

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
      <system.webServer>
        <!-- Don't show directory listings for URLs which map to a directory. -->
        <directoryBrowse enabled="false" />
        <rewrite>
          <rules>
            <rule name="Protect files and directories from prying eyes" stopProcessing="true">
              <match url="\.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(\..*|Entries.*|Repository|Root|Tag|Template)$" />
              <action type="CustomResponse" statusCode="403" subStatusCode="0" statusReason="Forbidden" statusDescription="Access is forbidden." />
            </rule>
            <rule name="Force simple error message for requests for non-existent favicon.ico" stopProcessing="true">
              <match url="favicon\.ico" />
              <action type="CustomResponse" statusCode="404" subStatusCode="1" statusReason="File Not Found" statusDescription="The requested file favicon.ico was not found" />
            </rule>
            <!-- Rewrite URLs of the form 'x' to the form 'index.php?q=x'. -->
            <rule name="Short URLs" stopProcessing="true">
              <match url="^(.*)$" ignoreCase="false" />
              <conditions>
                <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
                <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
                <add input="{URL}" pattern="^/favicon.ico$" ignoreCase="false" negate="true" />
              </conditions>
              <action type="Rewrite" url="index.php?q={R:1}" appendQueryString="true" />
            </rule>
          </rules>
        </rewrite>

        <httpErrors>
          <remove statusCode="404" subStatusCode="-1" />
          <error statusCode="404" prefixLanguageFilePath="" path="/index.php" responseMode="ExecuteURL" />
        </httpErrors>

        <defaultDocument>
          <!-- Set the default document -->
          <files>
            <remove value="index.php" />
            <add value="index.php" />
          </files>
        </defaultDocument>
      </system.webServer>
    </configuration>
     

     

  • Re: Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    Mar 28, 2011 09:30 PM|dotnetnerd|LINK

    The errors show that you have problem with your web.config file. Please kindly check your code. You can refer to our tutorial and hope it will help. :)

  • Re: Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    Mar 29, 2011 04:51 AM|peters196|LINK

    1. It would appear obvious that the problem is with the web.config file - the error page says so!

    2.  I had already read through your tutorial before posting my message!

     your tutorial gives an example of exactly the type of error I am getting and in it config source accurately diagnoses the error:

    3: <system.webServer>
    4: </handlers>
    5: <remove name="StaticFile"/>

    However, as stated in my message all that is listed under 'config source' is

    -1:

    0:

    This does not tell me where or what the error is! 

     3. As you will see from my message I have already checked my code. Apart from the fact that it is unchanged wfom when I downoaded it from the drupal website I have read through it carefully, checking for mis-matching tags etc;  I have checked it with the XML validator on the W3Schools website; I have opened it in Internet explorer and Firefox (which, according to another tutorial suggests that if an error is found the display of the file is truncated); I also commented out various sections of XML code until only the <configuration> and <system.webserver> tags remained.

    I am using Windows 7 ultimate which was installed clean on a new computer just a few days ago, with all current updates. It is, therefore unlikely that the web.config file in the Windows\System folder would be corrupted. Nevertheless I subjected that file to the same validity checks.

    I am no expert on the individual web.config tags and their parameters which is why I included a listing of the Drupal web.config file in my original message

    4. To answer you final point - Thank you for your prompt reply, but no! I'm afraid it doesn't help!

  • Re: Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    Apr 04, 2011 02:44 AM|Lloydz|LINK

    Hi,

    The web.config content seems to be correct. If you use a clean web.config copy, does the problem persist? If the issue can be solved by replacing web.config with clean configuration content, then the problem is exactly with this web.config. In this case, I suggest you remove partial of the web.config content to narrow down the issue. For example, make a backup for your web.config first, then remove the rewrite section and test. If the problem persists, remove the httpErrors section, and so on. If the pages shows correctly after you remove one section, then the problem is with that section. You need double check what's wrong with the section and update the correct configuration.

    If the problem remains even with clean web.config content, I suggest you access other pages in different folder in your site to see if the problem still exists. Also please check whether you have missed any specific drupal related settings that cause the issue.

    Hope this helps, thanks.

  • Re: Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    Apr 04, 2011 04:11 AM|peters196|LINK

    Thank you for your suggestion.

    This is exactly what I did over this last weekend (before seeing your message). It was then that i discovered that by removing the whole of the rewrite section it worked ok. Then, after a lot of searching I found that to use the rewrite tags required me to download and install another component, the rewrite module! (which seems strange as it would appear that most other IIS components are already installed - they just need enabling!)

    Any way, after installing the rewrite module the web.config file loaded without error and I can now start the uphill task of finding my way around Drupal!!!

    It would have been nice if a more meaningful error message could be generated for a missing module!    

  • Re: Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    Jan 22, 2013 05:27 AM|mshe2011|LINK

    Thank you very much,

    I installed that and it solved my problem.

    I have been messing around with blogs and appsettings.config file but none them were helpfull.

    As you said, It would have been really helpfull with more sensible error message

  • Re: Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    May 27, 2013 12:41 PM|doglin82|LINK

    Hi:
    I have installed the Rewrite Module and that solved my problem too. I am running IIS7.5. But I want to know why, you would get an error from IIS if you are missing the Rewrite Module and your config has the <rewrite> tag, and then the error you got is Config Source: -1: not able to read the config source.

    My guess is that without the Rewrite Module, IIS, doesn't know how to render the <rewrite> tag in your web.config file.

    Can someone with more expertise either confirm or disupte this theory?

     

    Many thanks

     

    iis7.5 web.config

  • Re: Error 500.19 Error Code: 0x8007000d Config source -1: 0:

    Jun 28, 2013 05:06 AM|Phil.Hartmann|LINK

    I had the same issue with but with the IIS Node.js extension with IIS 8 today.

    So it seems that this error is with any tag it doesnt know how to render? It would be great if IIS would capture the line it can't figure out as this is a rather painful issue to figure out given the complete lack of useful information in the error. Seems easy enough to reproduce.

    iis7.5 web.config