We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Web site will not start - The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80 for site 1. The URL may be invalid. The site has been disabled. The data field contains the error number. [Answered]RSS

2 replies

Last post Aug 01, 2012 11:42 AM by TravisDev

  • Web site will not start - The World Wide Web Publishing Service (WWW Service) did not register th...

    Jan 18, 2011 02:20 PM|philsteinberg|LINK

    Recently I ran into the following error and after 5 hours of worked accidently stumbled upon a solution.  I hope this helps someone out.

    The error was:

    "The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80 .... for site 1. The URL may be invalid. The site has been disabled. The data field contains the error number."

    After searching though google for many hours the only response to this I could find was that there was another application running that was using the same port.

    I verified that this was not the case.  Here is what actually happened:

    I was attempting to set up a Silverlight Web application to work with SSL WCF calls.  I kept getting Cross Domain errors even though I had set up a ClientAccessPolicy.xml file.  I decided to call the Silverlight Web application securely as well and I changed the project URL to use HTTPS.  However, when I did this, I keyed in the URL incorrectly.

    After I put this in I could no longer access the web site at all.  I checked IIS and found the web site was stopped.  When I tried to restart it I received the following error:

    "Value does not fall within the expected range."

    After searching on this people were indicating that I had a bad binding.  I removed them all and added them back with no success.

    I checked the event viewer and found the above error.  I saw my bad URL listed.  Unfortunately, I could not figure out how to clear it.

    When I searched the error I found the error code on Microsoft's tech site.  All it said was to clear out the bad URL and restart IIS but it did not indicate how to clear it out.

    I continued searching always finding the duplicate port issue.

    Finally, I found an entry from Microsoft indicating I had to fix the registry and delete the url from the ListenOnlyList registry key. When I searched here, It turned out I did not have the subkey so it was supposed to use the default of 0.0.0.0.  I tried adding the key but that did not help either so I deleted it.

    I was now at the point of giving up and reinstalling IIS, however, I  had seen multiple entries indicating that reinstalling did not help and they had to reformat and start from scratch.

    I decided to see if IIS had any configuration files that may have been corrupted.

    In the C:\Windows\System32\inetsrv\config folder I found the applicationHost.config file and it had been updated.

    I opened it up and in the <Sites> tag I found an application with my bad URL.   I deleted the application from the config file and I was able to restart the Web site and everything returned to normal.

     So if you change your URL in VS 2010 make sure you key it correctly or you could run into the same issue.

    IIS7 Web site will not start Value does not fall within the expected range World Wide Web Publishing Service

  • Re: Web site will not start - The World Wide Web Publishing Service (WWW Service) did not registe...

    Jan 19, 2011 01:51 AM|qbernard|LINK

    Good sharing, the config file by right should be clean up when you make changes to binding @ the IIS Manager :)

    Cheers,
    Bernard Cheah
  • Re: Web site will not start - The World Wide Web Publishing Service (WWW Service) did not registe...

    Aug 01, 2012 11:42 AM|TravisDev|LINK

    Wow. Thank you for sharing.  I got the same error when a website I created had a "C#" folder in it's path.  Deleting the site from the config file you mentioned fixed it for me!!