We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

WebPI CLI tool fails [Answered]RSS

1 reply

Last post Jan 12, 2011 02:03 AM by simtan

  • WebPI CLI tool fails

    Jan 11, 2011 08:42 PM|jcoburn|LINK

    I installed WebPI 3.0 and then the webpicmdline.exe tool and get the following error:

     C:\webmatrix\webpicmdline>webpicmdline.exe /Products:IIS7,Tracing,NETFramework35
    ,NETFramework4,ASPNET,MVC,WDeploy,FTPServer,ManagementService,CGI,URLRewrite2,SM
    O,PHP52,WinCache52,MySQLConnector,SQLDriverPHP52IIS

    Unhandled Exception: System.IO.FileLoadException: Could not load file or assembl
    y 'WebpiCmdLine, Version=0.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e
    35' or one of its dependencies. Strong name validation failed. (Exception from H
    RESULT: 0x8013141A)
    File name: 'WebpiCmdLine, Version=0.0.0.0, Culture=neutral, PublicKeyToken=31bf3
    856ad364e35' ---> System.Security.SecurityException: Strong name validation fail
    ed. (Exception from HRESULT: 0x8013141A)
    The Zone of the assembly that failed was:
    MyComputer

    Here's what it's in the same folder as the .exe

     C:\webmatrix\webpicmdline>dir
     Volume in drive C has no label.
     Volume Serial Number is C86D-7C28

     Directory of C:\webmatrix\webpicmdline

    01/11/2011  08:29 PM    <DIR>          .
    01/11/2011  08:29 PM    <DIR>          ..
    01/11/2011  08:29 PM         1,196,032 Microsoft.Web.Deployment.dll
    01/11/2011  08:29 PM           327,680 Microsoft.Web.PlatformInstaller.dll
    01/11/2011  08:29 PM           540,672 Microsoft.Web.PlatformInstaller.UI.dll
    01/11/2011  08:29 PM            81,920 WebpiCmdLine.exe
                   4 File(s)      2,146,304 bytes
                   2 Dir(s)  20,855,857,152 bytes free

     

  • Re: WebPI CLI tool fails

    Jan 12, 2011 02:03 AM|simtan|LINK

    Hello,

    After some internal investigation, it seems that this copy of webpicmdline is not fit for public use (not signed). It will take us some time to correct this; in the meanwhile, you'll have to install the server components manually by following the instructions here:

     http://learn.iis.net/page.aspx/951/install-server-components/

    Apologies for the inconvenience.

    Simon Tan
    Program Manager
    Web Platform and Tools