We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS [Answered]RSS

15 replies

Last post Jul 29, 2010 03:01 PM by ICIT

  • Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 11:15 AM|ICIT|LINK

    How do I fix this situation I'm currently running iis7 with php 5.2.4 /mysql 5.0.45 on ms server 2008 express

    I'm using Joomla as my CMS and trying to load one of the extensions and I'm receiving this

    HTTP Error 500.0 - Internal Server Error
    The page cannot be displayed because an internal server error has occurred.

    detailed error info:

    Module IsapiModule
    Notification ExecuteRequestHandler
    Handler PHP
    Error Code 0x00000000
    Requested URL http://......./administrator/index.php
    Physical Path C:\inetpub\........\administrator\index.php
    Logon Method Anonymous
    Logon User Anonymous

    I run the FailureLog Trace from with in IIS7 and obtained this below any help would be greatly appreciated.

    -MODULE_SET_RESPONSE_ERROR_STATUS 

    <div style="DISPLAY: block" id=section_detail_61_details class=hidden>
    ModuleName IsapiModule
    Notification 128
    HttpStatus 500
    HttpReason Internal Server Error
    HttpSubStatus 0
    ErrorCode 0
    ConfigExceptionInfo
    Notification EXECUTE_REQUEST_HANDLER
    ErrorCode

    The operation completed successfully. (0x0)                                            

     

    </div>

    IIS 7.0 Module set response error status

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 11:44 AM|don.raman|LINK

    Hi,

    Is anything getting written into PHP error log?

    Another thing please move to PHP5.2.14 and MySQL 5.1.49. There are many bug fixes in PHP and moving to latest version is suggested by core PHP developers.

    Thanks,

    Don.

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 12:15 PM|ICIT|LINK

    Don

     I will look to update allthough I tried to install the latest PHP version in the beginning but some install files where missing or different from the older version ex. libmysql.dll and php-in.dist and php-ini recommend where not visible or where named differnently.

    Also Mysql was missing some key files as well from its current version. but I'm assuming now that I'm stable I should be able to upgrade alot easier then trying to do a fresh install  

     by the way I'm currently using my desktop to build my website on a localhost would that affect how applications respond to installing them on the server

    How can I locate the PHP log files?

    Thanks for the quick response

    ICIT

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 12:33 PM|don.raman|LINK

    ICIT

    How can I locate the PHP log files?

    Open your php.ini file and see if error_log is configured to a proper file. This is where PHP will log errors. Alternatively you can add below two lines to get error logged:

    log_errors=On
    error_log="C:\WINDOWS\temp\php-errors.log"

    Please ensure that error log gile is writeable by your web server.

    Thanks,

    Don.

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 03:18 PM|ICIT|LINK

    Don

    error_log is on and I check window/temp/php-error and the file is there but the last action is showing on the 16th of July. I have not had the problem that long.

     is there any reason its not logging any more. I repeated the install to see if it would record anything and its still stating last log in was 10 days ago. This Appear to be around the time I first started setting up IIS7 and PHP/MySQL etc... no more reports since then

     

    [16-Jul-2010 12:56:51] PHP Warning:  PHP Startup: wincache: Unable to initialize module
    Module compiled with module API=20060613
    PHP    compiled with module API=20090626
    These options need to match
     in Unknown on line 0
    [16-Jul-2010 12:56:52] PHP Warning:  PHP Startup: sqlsrv: Unable to initialize module
    Module compiled with module API=20060613
    PHP    compiled with module API=20090626
    These options need to match
     in Unknown on line 0
    [16-Jul-2010 12:57:22] PHP Warning:  PHP Startup: wincache: Unable to initialize module
    Module compiled with module API=20060613
    PHP    compiled with module API=20090626
    These options need to match
     in Unknown on line 0
    [16-Jul-2010 12:57:22] PHP Warning:  PHP Startup: sqlsrv: Unable to initialize module
    Module compiled with module API=20060613
    PHP    compiled with module API=20090626
    These options need to match
     in Unknown on line 0
    [16-Jul-2010 13:00:01] PHP Warning:  PHP Startup: wincache: Unable to initialize module
    Module compiled with module API=20060613
    PHP    compiled with module API=20090626
    These options need to match
     in Unknown on line 0
    [16-Jul-2010 13:00:01] PHP Warning:  PHP Startup: sqlsrv: Unable to initialize module
    Module compiled with module API=20060613
    PHP    compiled with module API=20090626
    These options need to match
     in Unknown on line 0

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 03:43 PM|don.raman|LINK

    Hi,

    This seems like you had the listed extension built from different Visual Studio compiler. Since the error is not getting logged, seems like all the modules are getting loaded fine. Try a simple phpinfo() page and see if all the desired extensions are getting loaded or not. In order to see if the error is getting logged or not write a buggy small PHP code like the one below and try running it.

    <?php

    echo("hello world";

    ?>

    This should log the below line in the error log:

    [26-Jul-2010 12:42:19] PHP Parse error:  syntax error, unexpected ';' in C:\inetpub\wwwroot\phptest\bug.php on line 3

    Another thing, can you exactly tell me what steps you are doing in Joomla which is giving you 500. Exact steps please. I will try doing that at my end.

    Thanks,

    Don.

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 04:45 PM|ICIT|LINK

    On Joomla I'm looking to install VirtueMart 1.1.5 (stable) complete package that's installed using Joomla. its states that the install was successful 

    VM snapshot

    from there once I click load sample data or go directly to store that when the error occurs... All modules and plugins loads successfull just the creating of the tables and the database has issues 

    I ran the bug file and still no error_log although it did bring up the

    HTTP Error 500.0 - Internal Server Error

    The page cannot be displayed because an internal server error has occurred

    traced it and its still comeback to the MODULE_SET_RESPONSE_ERROR_STATUS

    MODULE_SET_RESPONSE_ERROR_STATUS 

    <div style="DISPLAY: block" id=section_detail_61_details class=hidden>
    ModuleName IsapiModule
    Notification 128
    HttpStatus 500
    HttpReason Internal Server Error
    HttpSubStatus 0
    ErrorCode 0
    ConfigExceptionInfo
    Notification EXECUTE_REQUEST_HANDLER
    ErrorCode

    The operation completed successfully. (0x0) 

    </div>
  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 04:52 PM|don.raman|LINK

    don.raman

    log_errors=On
    error_log="C:\WINDOWS\temp\php-errors.log"

    Are these two ini directives set? Is the same ini file getting picked? Did you restart IIS after changing the INI file?

    Thanks,

    Don.

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 05:10 PM|ICIT|LINK

    yes there is no semi colon and this is what I have for in the php.ini file

    ; Log errors into a log file (server-specific log, stderr, or error_log (below))
    ; As stated above, you're strongly advised to use error logging in place of
    ; error displaying on production web sites.
    log_errors = On
    error_log="C:\WINDOWS\temp\php-errors.log"

    Not sure if I know how to tell if Same ini file is getting picked I would assume it pulling from the C:\windows\php.ini

    and yes I did reset the server with in IIS7

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 05:14 PM|ICIT|LINK

    Right now I'm looking at upgrading to the latest version of PHP and MYSQL to see how this effect the installing process of  VM on Joomla...

    I currently have a copy of my database of Joomla so I'm ready to mess something up LOL

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 05:32 PM|don.raman|LINK

    ICIT

    Not sure if I know how to tell if Same ini file is getting picked I would assume it pulling from the C:\windows\php.ini

    The php.ini file gets picked up based on PHPRC environment variable. Look at your applicationHost.config to find where it is pointing to. Other way to find which php.ini is getting loaded is to run a simple phpinfo() page and look for "Loaded Configuration Files" at the top.

    Thanks,

    Don.

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 05:50 PM|ICIT|LINK

    After reading the install for the new upgrade of PHP 5.2.14 I notice that I did not do the activescript registration of the dll. in the current version of PHP because I was not able to download the php5activescript.dll file and place in the main folder

    http://pecl4win.php.net/  would that affect anything

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 26, 2010 05:53 PM|ICIT|LINK

    O.k this file is being read from its proper location 
    Loaded Configuration File

    C:\Windows\php.ini

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 27, 2010 10:58 AM|ICIT|LINK

    Don

    I updated to 5.2.14 I have to do MySql and I will update you on the outcome of doing the VM install on Joomla

    I would like to say thanks for your time in schooling me on this new server side technology you been a great help... if there is any surveys or any way I can give praise after getting things to work right just let me know

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 28, 2010 02:59 PM|ICIT|LINK

    I was not able to do the upgrade to Mysql 5.1.49 for some reason it would prepare and configure file but the service would not start.

    reverted back to 5.0.45

    is there anyway to figure out the issue via the failurelog trace Don?

  • Re: Noob having issues with IIS7 MODULE_SET_RESPONSE_ERROR_STATUS

    Jul 29, 2010 03:01 PM|ICIT|LINK

    Don

     I was able to update to the latest on both PHP and MYSQL now I'm receiving this error

     LOG_FILE_MAX_SIZE_TRUNCATE 

    how do I fix this