We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

IIS 7.5 HTTP Error 500.0RSS

3 replies

Last post Aug 05, 2010 05:35 PM by don.raman

  • IIS 7.5 HTTP Error 500.0

    Jul 19, 2010 01:25 PM|david78509|LINK

    Hello, I am installing a system called Myreview system. I faced a problem recently. The message says there is a internal error, as follows. HTTP error 500.0 - Internal Server Error Description: The page cannot be displayed because an internal server error has occurred. Module: FastCgiModule Requested URL:ExecuteRequestHandler Error Code: 0x00000000 Notification: ExecuteRequestHandler Requested URL: http://localhost:80/myreview_v2/www/index.php Physical Path: C:\inetpub\wwwroot\myreview_v2\www\index.php Logon User: Not yet determined Logon Method: Not yet determined Any help is appreciated, thanks.
  • Re: IIS 7.5 HTTP Error 500.0

    Jul 19, 2010 03:41 PM|don.raman|LINK

    Hi,

    I hope a simple phpinfo file is working correctly. This would ensure that PHP is working well.

    If PHP is working correctly, you would definitely like to check PHP error log and Windows Event Viewer.

    Thanks,

    Don.

  • Re: IIS 7.5 HTTP Error 500.0

    Aug 05, 2010 05:16 PM|mysorian|LINK

     Well I am in the same boat.

    I am using FastCGI with IIS 7.0

    1. Why do I get a IIS7.5 message?

     Test php page works as expected.

    The page that faults is a page that accesses SQL Server Database.

    Where do I find this PHP error log.

    I gave full permission to System and I am running IIS 7 as an admin.

    Any help is appreciated.

    IIS 7.5 php 5.2.1 iis7.0

    jay
  • Re: IIS 7.5 HTTP Error 500.0

    Aug 05, 2010 05:35 PM|don.raman|LINK

    Open your php.ini file which is getting loaded and see where your ini directive error_log is pointing to. The errors will be logged into that file.

    If you do not have error logging configured please add:

    log_errors=On
    error_log="C:\Windows\temp\php-errors.log"

    Also ensure that

    error_reporting = E_ALL

    is set in php.ini file.

    Restart your IIS and error should start getting logged. You can also disable in your browser to turn off to display HTTP friendly erros. For IE look at http://support.microsoft.com/kb/294807.

    Thanks,

    Don.